将设为首页浏览此站
开启辅助访问 天气与日历 收藏本站联系我们切换到窄版

易陆发现论坛

 找回密码
 开始注册
查看: 4028|回复: 2
收起左侧

VLAN接口动态获取IP地址配置

[复制链接]
发表于 2018-5-23 21:17:57 | 显示全部楼层 |阅读模式

马上注册,结交更多好友,享用更多功能,让你轻松玩转社区。

您需要 登录 才可以下载或查看,没有帐号?开始注册

x
VLAN接口动态获取IP地址配置, `# M& U& u5 B2 F$ [

2 z  R6 B( E: L  y『配置环境参数』
. Y$ A+ P. B( a+ ]1 t" m8 Z  j2 {3 r# T4 I4 y
1.SwitchA为二层交换机,管理VLAN为VLAN10
" r5 X) j. W' \8 `& O/ L8 W7 b3 D7 }
2.SwitchA的以太网端口E0/1为Trunk端口,连接到SwitchB,同时SwitchB提$ c1 v- T5 v' G/ P+ ?) o+ u
供DHCP Server功能
) R, \% j% a- v! J- F. o' p, Z4 ?0 l' H0 H" w; h0 [
『组网需求』
9 R3 P4 d! N# O7 W, H; Z! z( A! c* K
SwitchA的VLAN接口10动态获取IP地址数据
% L& S8 n1 N9 @# h  Z5 _9 Y$ U8 M" r4 z- A9 w7 h* V. g0 b
配置步骤( r- w% I$ W. Z4 j1 d
( `" Y1 B1 Z4 [& B
『VLAN接口动态获取IP地址配置流程』
6 A! j* U8 j, q# X5 V; a+ g) a
5 `4 P% t1 c9 m2 R& @在VLAN接口上配置动态获取IP地址。+ h) o* p! l) w" F6 ?: M

7 W! [1 b1 [8 V4 G8 ^【SwitchA相关配置】
* I/ n1 x& D0 X
2 W0 H6 a, G& l2 [' a0 y1.将E0/1端口设为trunk,并允许所有的vlan通过
8 F, `( ?' j# {4 O
% F9 D4 X1 f" y) ?6 T[SwitchA-Ethernet0/1]port link-type trunk
* W! P) q+ g# s3 f( {: K$ ~/ F1 D# d; u& ]' a- m0 X3 ?" A  n) i
[SwitchA-Ethernet0/1]port trunk permit vlan all: U/ P; @0 t& w7 R; P
- d$ X( D# Q1 k* b+ A9 C0 S
2.创建(进入)VLAN10
/ H1 W, C( T3 A! C5 i8 _/ C; a4 _# A% S
[SwitchA]vlan 10
 楼主| 发表于 2018-5-23 21:20:45 | 显示全部楼层
配置中继
* `0 {/ m* o. n) o, H' P步骤 交换机1命令 交换机2命令 作用
5 t; y/ U; D0 j9 L( N: ?4 s" v1 SW1#config terminal SW2#config terminal 进入特权模式
7 p& d# G5 E3 m, j  ]' I2 SW1(config)#interface f0/24 SW2(config)#interface f0/24 进入接口配置模式
( r" ]! a$ Z& ^2 {3 SW1(config-if)#switchport mode trunk SW2(config-if)#switchport mode trunk 将F0/24口配置为中继5 c! q8 r4 C) M
4 SW1(config-if)#end SW2(config-if)#end 返回特权模式/ ?" \" n/ Z. F4 T! Z* G" L% _
5 SW1#show interface f0/24 switchport SW2#show interface f0/24 switchport 查看F0/24的中继状态" N1 x, c- a1 \7 I- Q: x
四、将接口加入vlan8 V" r/ R  t1 D; }% i& g3 A
步骤 交换机1命令 交换机2命令 作用: I; e- u% i& O5 d' E5 a
1 SW1#config terminal SW2#config terminal 进入特权模式* u, B& c+ P* i0 n& B8 k  w/ C
2 SW1(config)#interface range f0/1 - 10 SW2(config)#interface range f0/1 - 10 进入接口配置模式
7 k( D$ r5 W3 b' e/ V# v! W1 ?SW1(config-if-range)#switchport access vlan 2 SW1(config-if-range)#switchport access vlan 2 将f0/1-10分配给valn2. x/ j# O& j* }$ k
SW1(config-if-range)#interface range f0/11 – 20 SW1(config-if-range)#interface range f0/11 – 20 进入f0/11-20的接口配置模式
5 q! V( E+ T+ i% O# B, b2 A& ASW1(config-if-range)#switchport access vlan 3 SW1(config-if-range)#switchport access vlan 3 将接口分配vlan 3
) g* l. u& l' ?% k3 \9 b# MSW1(config-if-range)#end SW1(config-if-range)#end 返回特权模式8 Q& `: ~& o9 C* o3 z4 x* L8 S* D
SW1#show vlan brief SW1#show vlan brief 查看vlan 情况
发表于 2018-5-23 22:40:51 | 显示全部楼层
用交换机根据端口划分vlan。
% m& [; T  V1 P1 Dswitch#vlan database
! |6 j: }! o/ n6 w$ jswitch(vlan)#vlan 10 name v1% Q  F! w8 r: J* ?2 j
//此步为划分出一个id是10名字是v1的vlan; Q) Y4 q% n4 e% T1 J% V) A. j
switch(vlan)#exit
4 h+ h+ I1 r- e7 M7 b" E! A3 sswitch#configure terminal/ u! ?+ P2 q0 Q
switch(config)#interface f0/1
0 \# K  @% d& Q  G1 d1 M+ ^switch(config-if)#switchport access vlan 10
% E8 A- N+ }' j  ?* x: ?* K//此步为把f0/1划分给vlan 10,即与f0/1相连的计算机划分给vlan 10。0 ~3 [& {1 W  a7 z
switch(config-if)#interface f0/2# x4 F. M4 l* Y. C: X
switch(config-if)#switchport mode trunk% U0 m- d5 }  ?( O; @3 u7 Y
//f0/2为交换机间的接口。
$ e# T7 c2 V2 E- `* _//此步为把两台交换机间的接口配置成trunk模式,以便不同vlan能通信。
/ Y: j# U3 r; \! Q8 B如果要实现线路冗余,可在交换机间配置快速生成树。
5 V+ h+ u; `  Z( l9 kswitch(config)#spanning-tree vlan 10* Q* F4 x# D! G' T# R2 v2 l
switch(config)#spanning-tree mode rapid-pvst
: _0 S) b* O. a9 g; b用路由器实现vlan间通信,防止外部访问本公司网络。
2 y! B3 u! c5 `! \router(config)#interface f0/2
5 Y& z9 i% b  h+ M# n: a  T/ u4 k, j//f0/2为路由器与交换机之间的接口。
% {6 D" g2 \( w, Q3 r6 srouter(config-if)#no shutdown% n! ]) ?( I2 X
router(config-if)#interface f0/0.10
- a! I( a3 b3 i: [router(config-subif)#encapsulation dot1q 10
3 I8 Z) b: s& j, V//10为vlanid
9 j! x; e6 Q8 V4 D4 W3 irouter(config-subif)#ip address 192.168.1.1 255.255.255.0
" \$ L6 P* Q* g//此步为配置单臂路由,实现vlan间通信。
  l. F1 D5 Z6 i% h) yrouter(config)#access-list 1 deny 10.10.1.0 0.0.0.255
7 ?( c) Z' m+ `# [; N. yrouter(config)#access-list 1 deny 10.10.2.0 0.0.0.255
/ |# C3 C# L! m! @1 P: {6 ?4 r1 p//10.10.1.0和10.10.10.2.0为内网ip。
, d9 b$ U8 ^8 P) d- a' b1 Orouter(config)#access-list 1 permit any) Z  x0 F% C8 L$ U
router(config)#interface f0/05 n0 l; @8 g5 ^9 E; ^0 ?
router(config-if)#ip access-group 1 out
$ U* _- S  K4 b, Q7 }- N& N//f0/0为路由器与外网接口。
) K1 M  [0 r1 j. H& O( L  N//此步配置访问控制列表,限制外网访问内网。
  D$ K( Y5 O- x3 K) D3 s以上配置全是思科的设备。# y+ v) C2 b. w; m9 K
内部网络用私有ip地址即可。私有ip地址网段分别为10.0.0.0-10.255.255.255和172.16.0.0-172.31.255.255和192.168.0.0-192.168.255.255, C+ X/ V9 ~9 g
不同vlan的ip可以在同网段,也可以不同。
您需要登录后才可以回帖 登录 | 开始注册

本版积分规则

关闭

站长推荐上一条 /4 下一条

如有购买积分卡请联系497906712

QQ|返回首页|Archiver|手机版|小黑屋|易陆发现 点击这里给我发消息

GMT+8, 2021-9-27 02:50 , Processed in 0.042174 second(s), 21 queries .

Powered by LR.LINUX.cloud bbs168x X3.2 Licensed

© 2012-2022 Comsenz Inc.

快速回复 返回顶部 返回列表