将设为首页浏览此站
开启辅助访问 天气与日历 收藏本站联系我们切换到窄版

易陆发现论坛

 找回密码
 开始注册
查看: 381|回复: 2
收起左侧

openstack complete 出现 No module named v1_1处理过程

[复制链接]
发表于 2021-9-8 15:01:40 | 显示全部楼层 |阅读模式

马上注册,结交更多好友,享用更多功能,让你轻松玩转社区。

您需要 登录 才可以下载或查看,没有帐号?开始注册

x
[root@controller1 ~]# openstack complete & H5 o+ |# f5 r5 d4 ~
No module named v1_1: Z0 Q0 ~6 H' n) }& e9 |& U" H
[root@controller1 ~]# pip install os_diskconfig_python_novaclient_ext6 v4 }" w1 T- p* G
DEPRECATION: Python 2.7 reached the end of its life on January 1st, 2020. Please upgrade your Python as Python 2.7 is no longer maintained. pip 21.0 will drop support for Python 2.7 in January 2021. More details about Python 2 support in pip can be found at https://pip.pypa.io/en/latest/development/release-process/#python-2-support pip 21.0 will remove support for this functionality.
, n& K# P& }3 u# vLooking in indexes: http://mirrors.aliyun.com/pypi/simple/
" b% v0 g4 u! u+ RCollecting os_diskconfig_python_novaclient_ext
+ |, [2 N0 Z* Y3 G! q( k1 t: S  Downloading http://mirrors.aliyun.com/pypi/packages/40/1f/3adee4a7fc4d0dd7bb4578ab71d99d2735f0f450bced42459e66c2f22322/os_diskconfig_python_novaclient_ext-0.1.3-py2-none-any.whl (3.9 kB)
+ V( L9 ~* r! q0 \( I8 I, D6 q7 O5 k  jRequirement already satisfied: python-novaclient in /usr/lib/python2.7/site-packages (from os_diskconfig_python_novaclient_ext) (16.0.0)
5 O1 ?% A' N& ERequirement already satisfied: pbr!=2.1.0,>=2.0.0 in /usr/lib/python2.7/site-packages (from python-novaclient->os_diskconfig_python_novaclient_ext) (5.5.1)4 {( V& O! M6 f9 {# V
Requirement already satisfied: keystoneauth1>=3.5.0 in /usr/lib/python2.7/site-packages (from python-novaclient->os_diskconfig_python_novaclient_ext) (4.0.1)% e* b- v- g1 }0 w/ F, \5 r' t5 ?
Requirement already satisfied: oslo.i18n>=3.15.3 in /usr/lib/python2.7/site-packages (from python-novaclient->os_diskconfig_python_novaclient_ext) (3.25.1)" |6 Y4 m% m% D* Z
Requirement already satisfied: six>=1.10.0 in /usr/lib/python2.7/site-packages (from python-novaclient->os_diskconfig_python_novaclient_ext) (1.16.0)0 R# o# t2 i+ `8 I1 T
Requirement already satisfied: oslo.serialization!=2.19.1,>=2.18.0 in /usr/lib/python2.7/site-packages (from python-novaclient->os_diskconfig_python_novaclient_ext) (2.29.3)
; B: g9 G/ Q) k0 F$ }1 ?1 ERequirement already satisfied: simplejson>=3.5.1 in /usr/lib64/python2.7/site-packages (from python-novaclient->os_diskconfig_python_novaclient_ext) (3.10.0): W' A5 P; \7 x/ e# [4 ^
Requirement already satisfied: iso8601>=0.1.11 in /usr/lib/python2.7/site-packages (from python-novaclient->os_diskconfig_python_novaclient_ext) (0.1.14)- w4 D: k2 `% O5 ~# u
Requirement already satisfied: PrettyTable<0.8,>=0.7.2 in /usr/lib/python2.7/site-packages (from python-novaclient->os_diskconfig_python_novaclient_ext) (0.7.2)0 t3 g4 P) |) o
Requirement already satisfied: oslo.utils>=3.33.0 in /usr/lib/python2.7/site-packages (from python-novaclient->os_diskconfig_python_novaclient_ext) (3.42.1)7 K/ |1 P  n, d* b
Requirement already satisfied: Babel!=2.4.0,>=2.3.4 in /usr/lib/python2.7/site-packages (from python-novaclient->os_diskconfig_python_novaclient_ext) (2.9.0)5 V5 k2 S9 k, y) C# m" [
Requirement already satisfied: stevedore>=1.20.0 in /usr/lib/python2.7/site-packages (from keystoneauth1>=3.5.0->python-novaclient->os_diskconfig_python_novaclient_ext) (1.32.0)
) s- y, ?. k( N- oRequirement already satisfied: requests>=2.14.2 in /usr/lib/python2.7/site-packages (from keystoneauth1>=3.5.0->python-novaclient->os_diskconfig_python_novaclient_ext) (2.26.0)
/ D4 B5 b* t6 e2 o# p& VRequirement already satisfied: os-service-types>=1.2.0 in /usr/lib/python2.7/site-packages (from keystoneauth1>=3.5.0->python-novaclient->os_diskconfig_python_novaclient_ext) (1.7.0)7 j( I. l) Z- H2 K# z. o
Requirement already satisfied: pytz>=2013.6 in /usr/lib/python2.7/site-packages (from oslo.serialization!=2.19.1,>=2.18.0->python-novaclient->os_diskconfig_python_novaclient_ext) (2021.1)
1 f4 n( ~( n( I; h, p/ WRequirement already satisfied: PyYAML>=3.12 in /usr/lib64/python2.7/site-packages (from oslo.serialization!=2.19.1,>=2.18.0->python-novaclient->os_diskconfig_python_novaclient_ext) (5.4.1)" y! p& g' w0 y: m" ^/ A
Requirement already satisfied: msgpack>=0.5.2 in /usr/lib/python2.7/site-packages (from oslo.serialization!=2.19.1,>=2.18.0->python-novaclient->os_diskconfig_python_novaclient_ext) (1.0.2)* ^+ G7 d* P# `! y
Requirement already satisfied: netifaces>=0.10.4 in /usr/lib64/python2.7/site-packages (from oslo.utils>=3.33.0->python-novaclient->os_diskconfig_python_novaclient_ext) (0.10.9)
! |% v1 S  d* L' U  D% M; ARequirement already satisfied: pyparsing>=2.1.0 in /usr/lib/python2.7/site-packages (from oslo.utils>=3.33.0->python-novaclient->os_diskconfig_python_novaclient_ext) (2.4.7)
: E! x2 ~' r, _- ]& ^0 u7 s# _$ U' sRequirement already satisfied: funcsigs>=1.0.0; python_version == "2.7" or python_version == "2.6" in /usr/lib/python2.7/site-packages (from oslo.utils>=3.33.0->python-novaclient->os_diskconfig_python_novaclient_ext) (1.0.2)
& g9 }) L8 I# a7 a: Z* ~7 XRequirement already satisfied: netaddr>=0.7.18 in /usr/lib/python2.7/site-packages (from oslo.utils>=3.33.0->python-novaclient->os_diskconfig_python_novaclient_ext) (0.8.0): {* s, m' L9 \0 M: M) X
Requirement already satisfied: debtcollector>=1.2.0 in /usr/lib/python2.7/site-packages (from oslo.utils>=3.33.0->python-novaclient->os_diskconfig_python_novaclient_ext) (1.22.0)
3 \1 t" I4 \. L. F& W: O* A" m6 hRequirement already satisfied: monotonic>=0.6; python_version < "3.3" in /usr/lib/python2.7/site-packages (from oslo.utils>=3.33.0->python-novaclient->os_diskconfig_python_novaclient_ext) (1.6)+ c3 D& k; H3 P' W8 p  n9 q
Requirement already satisfied: certifi>=2017.4.17 in /usr/lib/python2.7/site-packages (from requests>=2.14.2->keystoneauth1>=3.5.0->python-novaclient->os_diskconfig_python_novaclient_ext) (2021.5.30)+ `* o: d+ g7 b7 S
Requirement already satisfied: urllib3<1.27,>=1.21.1 in /usr/lib/python2.7/site-packages (from requests>=2.14.2->keystoneauth1>=3.5.0->python-novaclient->os_diskconfig_python_novaclient_ext) (1.26.6)
: j. M2 m7 H+ p  Y% qRequirement already satisfied: idna<3,>=2.5; python_version < "3" in /usr/lib/python2.7/site-packages (from requests>=2.14.2->keystoneauth1>=3.5.0->python-novaclient->os_diskconfig_python_novaclient_ext) (2.10)* I6 X4 ]5 X3 H! T) L, G
Requirement already satisfied: chardet<5,>=3.0.2; python_version < "3" in /usr/lib/python2.7/site-packages (from requests>=2.14.2->keystoneauth1>=3.5.0->python-novaclient->os_diskconfig_python_novaclient_ext) (4.0.0)6 ~8 N/ D- S8 F4 k  Z( D/ Y" h( d
Requirement already satisfied: importlib-resources; python_version < "3.7" in /usr/lib/python2.7/site-packages (from netaddr>=0.7.18->oslo.utils>=3.33.0->python-novaclient->os_diskconfig_python_novaclient_ext) (3.3.1)& x* S0 v% t  z
Requirement already satisfied: wrapt>=1.7.0 in /usr/lib64/python2.7/site-packages (from debtcollector>=1.2.0->oslo.utils>=3.33.0->python-novaclient->os_diskconfig_python_novaclient_ext) (1.12.1)
! Y7 ]$ L; N+ f6 h2 G% qRequirement already satisfied: singledispatch; python_version < "3.4" in /usr/lib/python2.7/site-packages (from importlib-resources; python_version < "3.7"->netaddr>=0.7.18->oslo.utils>=3.33.0->python-novaclient->os_diskconfig_python_novaclient_ext) (3.6.1)
) g' ?6 ], b% A3 `Requirement already satisfied: zipp>=0.4; python_version < "3.8" in /usr/lib/python2.7/site-packages (from importlib-resources; python_version < "3.7"->netaddr>=0.7.18->oslo.utils>=3.33.0->python-novaclient->os_diskconfig_python_novaclient_ext) (1.2.0)$ t# d  _8 K& h- E; [7 W' e
Requirement already satisfied: pathlib2; python_version < "3" in /usr/lib/python2.7/site-packages (from importlib-resources; python_version < "3.7"->netaddr>=0.7.18->oslo.utils>=3.33.0->python-novaclient->os_diskconfig_python_novaclient_ext) (2.3.5)
  h/ t; r0 T; O+ b/ PRequirement already satisfied: contextlib2; python_version < "3" in /usr/lib/python2.7/site-packages (from importlib-resources; python_version < "3.7"->netaddr>=0.7.18->oslo.utils>=3.33.0->python-novaclient->os_diskconfig_python_novaclient_ext) (0.6.0.post1)9 O, ?) T( P" w% K! g, C2 Z# k; `
Requirement already satisfied: typing; python_version < "3.5" in /usr/lib/python2.7/site-packages (from importlib-resources; python_version < "3.7"->netaddr>=0.7.18->oslo.utils>=3.33.0->python-novaclient->os_diskconfig_python_novaclient_ext) (3.7.4.3)
5 W  V1 o$ J3 S9 k  j0 w! lRequirement already satisfied: scandir; python_version < "3.5" in /usr/lib64/python2.7/site-packages (from pathlib2; python_version < "3"->importlib-resources; python_version < "3.7"->netaddr>=0.7.18->oslo.utils>=3.33.0->python-novaclient->os_diskconfig_python_novaclient_ext) (1.10.0)
0 {# l, b) v' u+ W1 H& tInstalling collected packages: os-diskconfig-python-novaclient-ext) v' {- W+ E8 P( J: |
Successfully installed os-diskconfig-python-novaclient-ext-0.1.33 M6 q4 h1 V3 l9 Z5 A. ?/ B
[root@controller1 ~]# openstack complete
0 ]( ^2 B7 P' v' j! p" dNo module named v1_1
2 u6 j- }. [- i" {& u+ J1 B& K  n[root@controller1 ~]# pip uninstall rax_default_network_flags_python_novaclient_ext# k2 A4 a- \( ]! V
DEPRECATION: Python 2.7 reached the end of its life on January 1st, 2020. Please upgrade your Python as Python 2.7 is no longer maintained. pip 21.0 will drop support for Python 2.7 in January 2021. More details about Python 2 support in pip can be found at https://pip.pypa.io/en/latest/development/release-process/#python-2-support pip 21.0 will remove support for this functionality.% L+ a2 d( h0 ~; E6 u5 C- m. G
WARNING: Skipping rax-default-network-flags-python-novaclient-ext as it is not installed.; M& }. b% X( H4 J; p
[root@controller1 ~]# pip uninstall os_diskconfig_python_novaclient_ext0 E0 L9 k+ m' |/ C" f
DEPRECATION: Python 2.7 reached the end of its life on January 1st, 2020. Please upgrade your Python as Python 2.7 is no longer maintained. pip 21.0 will drop support for Python 2.7 in January 2021. More details about Python 2 support in pip can be found at https://pip.pypa.io/en/latest/development/release-process/#python-2-support pip 21.0 will remove support for this functionality.
8 \2 g+ K! a  l0 hFound existing installation: os-diskconfig-python-novaclient-ext 0.1.3
$ r$ s; [" J9 l# DUninstalling os-diskconfig-python-novaclient-ext-0.1.3:
9 j8 V/ W# I/ ?  Would remove:
$ W4 R7 v* x* l' k& l    /usr/lib/python2.7/site-packages/os_diskconfig_python_novaclient_ext-0.1.3.dist-info/*3 C$ C( C) {& [8 O: V
    /usr/lib/python2.7/site-packages/os_diskconfig_python_novaclient_ext/*
- n9 h4 ~( _1 b( S/ z. `, A; ]) vProceed (y/n)? y& Q2 P. ~- A, n* o# H6 b7 S4 t' Q
  Successfully uninstalled os-diskconfig-python-novaclient-ext-0.1.37 b3 M) v7 K3 I0 ~2 ]1 O

  i: A+ J. M" K' B% Y! d' [9 U( V
Found existing installation: os-diskconfig-python-novaclient-ext 0.1.3! u; e$ V' Z, x; [: y2 @
Uninstalling os-diskconfig-python-novaclient-ext-0.1.3:
' D/ A/ s( K6 w! f  Would remove:* L: [7 g, r3 l6 O7 X  B) T
    /usr/lib/python2.7/site-packages/os_diskconfig_python_novaclient_ext-0.1.3.dist-info/*$ q# J8 ?3 b, Z" @* ^' D& p7 ?
    /usr/lib/python2.7/site-packages/os_diskconfig_python_novaclient_ext/*
+ q% F6 u! b5 Z# ?' z! X! pProceed (y/n)? y- K! e# o7 }2 l6 i
  Successfully uninstalled os-diskconfig-python-novaclient-ext-0.1.3+ M8 [2 @( g; D$ J

+ b; X6 m0 I; _, ~( R! D# S再次执行,依然是原来的错误:1 E0 y7 R3 g! g! A& }
[root@controller1 ~]# openstack complete
6 q; n+ Q9 d% M4 q/ k, [: M9 hNo module named v1_12 y, F7 L- I) K/ y. H
[root@controller1 ~]# sudo pip uninstall rackspace-novaclient
& Z% {' O. ^# V4 g7 d3 Q+ kDEPRECATION: Python 2.7 reached the end of its life on January 1st, 2020. Please upgrade your Python as Python 2.7 is no longer maintained. pip 21.0 will drop support for Python 2.7 in January 2021. More details about Python 2 support in pip can be found at https://pip.pypa.io/en/latest/development/release-process/#python-2-support pip 21.0 will remove support for this functionality." |8 n8 M* z0 k! l
WARNING: Skipping rackspace-novaclient as it is not installed.2 {! V5 J- ?; x8 [" C/ U! b, D+ p
[root@controller1 ~]# openstack complete
: V9 Z7 w4 M  KNo module named v1_1
; c7 |& J- ^7 ^4 t
5 V  B: p- o8 U( N! M8 y+ y7 j
% i0 {* o+ x2 ^4 x- i9 t5 I9 _( b暂时无解,只能考虑卸载之前安装的插件了。+ q2 q( i9 p( F; d# P+ i) @9 l6 Y0 {
) K3 c3 \1 i4 l7 A7 q! {
[root@controller1 ~]# pip uninstall rax_default_network_flags_python_novaclient_ext' p) L% S/ \3 `( ^( |
DEPRECATION: Python 2.7 reached the end of its life on January 1st, 2020. Please upgrade your Python as Python 2.7 is no longer maintained. pip 21.0 will drop support for Python 2.7 in January 2021. More details about Python 2 support in pip can be found at https://pip.pypa.io/en/latest/development/release-process/#python-2-support pip 21.0 will remove support for this functionality.
+ W% i# x! ]: ?WARNING: Skipping rax-default-network-flags-python-novaclient-ext as it is not installed.4 H, S; B6 a& k$ ^$ `- h; f
[root@controller1 ~]# pip uninstall os_diskconfig_python_novaclient_ext5 I' ^6 @- ]2 o. `  x* Z) a
DEPRECATION: Python 2.7 reached the end of its life on January 1st, 2020. Please upgrade your Python as Python 2.7 is no longer maintained. pip 21.0 will drop support for Python 2.7 in January 2021. More details about Python 2 support in pip can be found at https://pip.pypa.io/en/latest/development/release-process/#python-2-support pip 21.0 will remove support for this functionality.
6 \2 Q- K) H+ {! L$ Z: v  AFound existing installation: os-diskconfig-python-novaclient-ext 0.1.3; u7 S8 b( x$ Q) @  q, y0 R
Uninstalling os-diskconfig-python-novaclient-ext-0.1.3:
& V+ o" F1 K6 K! J. O5 [0 ]' Q  Would remove:
& u: M5 S: S/ P: J8 I2 f    /usr/lib/python2.7/site-packages/os_diskconfig_python_novaclient_ext-0.1.3.dist-info/*" N! Y/ [, G4 G4 n9 Y) z
    /usr/lib/python2.7/site-packages/os_diskconfig_python_novaclient_ext/*' u9 S- y0 b0 \. ^  }" n
Proceed (y/n)? y: s! p( X9 p" o& w
  Successfully uninstalled os-diskconfig-python-novaclient-ext-0.1.3( F4 k* W4 Q* R  X( Z6 p
[root@controller1 ~]# openstack complete ) t# H2 G' f! b6 E' F" j
No module named v1_1
, h6 ?+ m) y8 @' R! b[root@controller1 ~]# sudo pip uninstall rackspace-novaclient
$ ~! H* z% F. ]DEPRECATION: Python 2.7 reached the end of its life on January 1st, 2020. Please upgrade your Python as Python 2.7 is no longer maintained. pip 21.0 will drop support for Python 2.7 in January 2021. More details about Python 2 support in pip can be found at https://pip.pypa.io/en/latest/development/release-process/#python-2-support pip 21.0 will remove support for this functionality.- t3 F# w( \" l* x) Z
WARNING: Skipping rackspace-novaclient as it is not installed.
! ?' m6 `+ t( C3 z' @& K8 F7 T[root@controller1 ~]# openstack complete4 z7 j2 m) `$ A1 r0 C2 f: _
No module named v1_15 x- j: X! G  m
[root@controller1 ~]# pip uninstall python-openstackclient
/ d' E& q3 I7 z* n+ vDEPRECATION: Python 2.7 reached the end of its life on January 1st, 2020. Please upgrade your Python as Python 2.7 is no longer maintained. pip 21.0 will drop support for Python 2.7 in January 2021. More details about Python 2 support in pip can be found at https://pip.pypa.io/en/latest/development/release-process/#python-2-support pip 21.0 will remove support for this functionality.
9 ]: G. S/ B5 E" k4 y2 o3 LFound existing installation: python-openstackclient 1.9.07 `7 S$ Q! h3 J
Uninstalling python-openstackclient-1.9.0:* `7 O; n% u9 ^- K: b  t" l
  Would remove:
4 g- ^: L; g0 x) E0 L& A; W    /usr/bin/openstack
* V" ?7 F2 x9 ^: w" L1 e1 ^0 p    /usr/lib/python2.7/site-packages/openstackclient/*
4 x/ O, s) g5 q$ L, R    /usr/lib/python2.7/site-packages/python_openstackclient-1.9.0.dist-info/*
+ a* x" b: B5 uProceed (y/n)? y4 g6 y( W$ g$ R1 N% d
  Successfully uninstalled python-openstackclient-1.9.0: R) U# N. j% P- ^2 y! O8 X# X
[root@controller1 ~]# pip help uninstall: i* `; w" }& l4 Z  l5 ], C
DEPRECATION: Python 2.7 reached the end of its life on January 1st, 2020. Please upgrade your Python as Python 2.7 is no longer maintained. pip 21.0 will drop support for Python 2.7 in January 2021. More details about Python 2 support in pip can be found at https://pip.pypa.io/en/latest/development/release-process/#python-2-support pip 21.0 will remove support for this functionality.0 j5 ]0 U7 H$ l1 i2 D" e; s6 z
Usage:   
4 p: L( I/ K4 J+ i. H4 W% T' L  pip uninstall [options] <package> ...
: ^6 {3 W/ j: U& I) K, R. j% c  pip uninstall [options] -r <requirements file> ...
  J5 _* C" R! ]& ^Description:: O9 @. J1 c( C" ~+ z4 \, y
  Uninstall packages.
8 q( I' r1 p# }* ?6 f  
4 o" l- f% K1 h  pip is able to uninstall most installed packages. Known exceptions are:
: z& c4 \- [$ H. s" h/ H0 w  
5 l0 y2 N  y) z' b( m  - Pure distutils packages installed with ``python setup.py install``, which
5 P9 g$ |8 I) t5 W    leave behind no metadata to determine what files were installed.$ ?, t* y8 J: |0 q
  - Script wrappers installed by ``python setup.py develop``." ^3 Q9 Y5 J$ s7 E
Uninstall Options:; e; }# Q, {1 I/ a- V
  -r, --requirement <file>    Uninstall all the packages listed in the given requirements file.  This option can be used multiple times.
/ i5 _/ Y5 R( h: \3 O  l  k  -y, --yes                   Don't ask for confirmation of uninstall deletions.
" H5 q" ]9 V  B3 n7 l, y9 x) DGeneral Options:3 W5 D( E& s5 g8 i; Z
  -h, --help                  Show help.' h' q" B' Y: _
  --isolated                  Run pip in an isolated mode, ignoring environment variables and user configuration.
- ]6 C4 _- J  U! W) m9 ~; f' O  -v, --verbose               Give more output. Option is additive, and can be used up to 3 times.
& ?0 A6 V# }) h) H  -V, --version               Show version and exit.
" }: F! `8 u/ T6 y9 R  B5 }  -q, --quiet                 Give less output. Option is additive, and can be used up to 3 times (corresponding to WARNING, ERROR, and CRITICAL logging levels).4 L' a( K& ^! T3 }7 T
  --log <path>                Path to a verbose appending log.* u$ m0 k3 V( @' w" d1 a  v; M
  --no-input                  Disable prompting for input.* `; }. w% T( s# P' s
  --proxy <proxy>             Specify a proxy in the form [user:passwd@]proxy.server:port.
/ |/ y. F6 H1 F2 j2 U  --retries <retries>         Maximum number of retries each connection should attempt (default 5 times).
( d1 Y+ P: a7 i  \* q3 ?  --timeout <sec>             Set the socket timeout (default 15 seconds).; _. m1 V3 B* w+ ^
  --exists-action <action>    Default action when a path already exists: (s)witch, (i)gnore, (w)ipe, (b)ackup, (a)bort.! _# ]8 R) g# z3 }
  --trusted-host <hostname>   Mark this host or host:port pair as trusted, even though it does not have valid or any HTTPS.
1 s7 f9 X9 ^; w) G  --cert <path>               Path to alternate CA bundle.
* y" g, _, _6 p, F  L% Z  --client-cert <path>        Path to SSL client certificate, a single file containing the private key and the certificate in PEM format.
+ S9 N  q/ ~+ t  --cache-dir <dir>           Store the cache data in <dir>.5 h4 @" X: I2 F) S
  --no-cache-dir              Disable the cache.8 A  V6 a# T. {
  --disable-pip-version-check
% b2 l, @! d) j$ V  G( u                              Don't periodically check PyPI to determine whether a new version of pip is available for download. Implied with --no-index.
5 n( G* R! y1 ~+ T* |  --no-color                  Suppress colored output.# D- O9 e; z* O% O1 ]
  --no-python-version-warning
+ Z1 r$ d. m! x: Q9 O                              Silence deprecation warnings for upcoming unsupported Pythons.0 G3 H; T/ E$ V( L- y& T- D5 f: ?
  --use-feature <feature>     Enable new functionality, that may be backward incompatible.8 r/ V1 l" X3 i' U4 X9 a& Z" n
  --use-deprecated <feature>  Enable deprecated functionality, that will be removed in the future.( a0 j; ^) V8 e' V8 @9 Z
[root@controller1 ~]# pip uninstall python-openstackclient
. h0 N! b9 Q( k! P! XDEPRECATION: Python 2.7 reached the end of its life on January 1st, 2020. Please upgrade your Python as Python 2.7 is no longer maintained. pip 21.0 will drop support for Python 2.7 in January 2021. More details about Python 2 support in pip can be found at https://pip.pypa.io/en/latest/development/release-process/#python-2-support pip 21.0 will remove support for this functionality.
; j2 P' F: b! W" O$ OWARNING: Skipping python-openstackclient as it is not installed.& T9 E- E) \, ?- ^) u7 E
[root@controller1 ~]# pip uninstall  neutron
9 a+ r; S$ A3 o3 @3 wDEPRECATION: Python 2.7 reached the end of its life on January 1st, 2020. Please upgrade your Python as Python 2.7 is no longer maintained. pip 21.0 will drop support for Python 2.7 in January 2021. More details about Python 2 support in pip can be found at https://pip.pypa.io/en/latest/development/release-process/#python-2-support pip 21.0 will remove support for this functionality.
  Q1 H1 C+ M1 ?WARNING: Skipping neutron as it is not installed.
$ Y% r* ?4 n6 N; z) @" Z4 q[root@controller1 ~]# pip uninstall neutron' y+ ^" L' M8 g( w+ Z2 d4 ]7 K5 s
DEPRECATION: Python 2.7 reached the end of its life on January 1st, 2020. Please upgrade your Python as Python 2.7 is no longer maintained. pip 21.0 will drop support for Python 2.7 in January 2021. More details about Python 2 support in pip can be found at https://pip.pypa.io/en/latest/development/release-process/#python-2-support pip 21.0 will remove support for this functionality.( q: v- D# o2 V* [7 q
WARNING: Skipping neutron as it is not installed.
" |+ T! |+ n5 |0 v- S
+ v# y0 L* b8 @
/ C8 F# Q0 s( p5 o( @: {[root@controller1 ~]# pip uninstall pyroute2
: h4 K$ Z8 `6 ]" l4 ?5 zDEPRECATION: Python 2.7 reached the end of its life on January 1st, 2020. Please upgrade your Python as Python 2.7 is no longer maintained. pip 21.0 will drop support for Python 2.7 in January 2021. More details about Python 2 support in pip can be found at https://pip.pypa.io/en/latest/development/release-process/#python-2-support pip 21.0 will remove support for this functionality.& O( g1 c& Y2 ]" S8 {
WARNING: Skipping pyroute2 as it is not installed.7 S) T4 N& }9 M0 M& M8 I" s
[root@controller1 ~]# pip uninstall "pyroute2"
/ k) U$ \9 v0 y+ O2 `DEPRECATION: Python 2.7 reached the end of its life on January 1st, 2020. Please upgrade your Python as Python 2.7 is no longer maintained. pip 21.0 will drop support for Python 2.7 in January 2021. More details about Python 2 support in pip can be found at https://pip.pypa.io/en/latest/development/release-process/#python-2-support pip 21.0 will remove support for this functionality.' U9 |+ c6 ]  F9 j7 X
WARNING: Skipping pyroute2 as it is not installed." Q3 u% |3 ^3 s" P6 i
[root@controller1 ~]# pip uninstall "pyroute2*"
- s! t) o# z/ l* g2 ]DEPRECATION: Python 2.7 reached the end of its life on January 1st, 2020. Please upgrade your Python as Python 2.7 is no longer maintained. pip 21.0 will drop support for Python 2.7 in January 2021. More details about Python 2 support in pip can be found at https://pip.pypa.io/en/latest/development/release-process/#python-2-support pip 21.0 will remove support for this functionality.
0 Y7 l* K! L4 `! I/ wERROR: Invalid requirement: 'pyroute2*'
: x/ v4 O+ q- }& ?- c4 t[root@controller1 ~]# pip uninstall "pyroute2"* D2 R9 S  W: z! d$ ~' O
DEPRECATION: Python 2.7 reached the end of its life on January 1st, 2020. Please upgrade your Python as Python 2.7 is no longer maintained. pip 21.0 will drop support for Python 2.7 in January 2021. More details about Python 2 support in pip can be found at https://pip.pypa.io/en/latest/development/release-process/#python-2-support pip 21.0 will remove support for this functionality.# \2 j) S9 m$ D
WARNING: Skipping pyroute2 as it is not installed.: G# P) N  y4 R  n9 V' q
[root@controller1 ~]# pip uninstall python-openstackclient python-glanceclient python-neutronclient, t. e- O4 M. j
DEPRECATION: Python 2.7 reached the end of its life on January 1st, 2020. Please upgrade your Python as Python 2.7 is no longer maintained. pip 21.0 will drop support for Python 2.7 in January 2021. More details about Python 2 support in pip can be found at https://pip.pypa.io/en/latest/development/release-process/#python-2-support pip 21.0 will remove support for this functionality.% T. x7 z7 u8 u1 x- k, K0 N3 r
Found existing installation: python-neutronclient 7.1.0
. Q3 z9 T- [! ~8 K5 JUninstalling python-neutronclient-7.1.0:
9 e  [! V4 d; [) [$ ?  Would remove:, ?$ x* J! r; Z9 |
    /usr/bin/neutron' l$ ?( ]/ }0 B9 g" @8 q5 ~
    /usr/lib/python2.7/site-packages/neutronclient/*
2 S. b" Z7 L6 l9 w7 @, J; J    /usr/lib/python2.7/site-packages/python_neutronclient-7.1.0.dist-info/*7 m: d2 c( \$ o7 e$ V
Proceed (y/n)? y
3 w) w" I" E  a  Successfully uninstalled python-neutronclient-7.1.0* J: t1 L: Y  y8 K
WARNING: Skipping python-openstackclient as it is not installed.
$ E# P$ _* W2 }Found existing installation: python-glanceclient 3.0.0# b! ?, l+ d' J4 w" |
Uninstalling python-glanceclient-3.0.0:
0 |! p. `8 d4 @  Would remove:* X4 W; Z2 F& b+ o3 I/ }) ~2 V: P6 R! _
    /usr/bin/glance6 x5 Z* S) N; u. s4 f
    /usr/lib/python2.7/site-packages/glanceclient/*( [6 Y1 A4 W; M3 r
    /usr/lib/python2.7/site-packages/python_glanceclient-3.0.0.dist-info/*% [: Z  _. Z- X6 j9 R
Proceed (y/n)? y
8 K" `2 z! \- d7 j% _, y  Successfully uninstalled python-glanceclient-3.0.0
' Z6 Y' q3 J% M0 J1 J& H4 A, S- v3 n# A
[root@controller1 ~]#
0 _; |1 `' N$ X[root@controller1 ~]#
6 q  [* R; [% G3 [3 H[root@controller1 ~]# pip uninstall pyrsistent7 p4 D! b9 i; V; n) J
DEPRECATION: Python 2.7 reached the end of its life on January 1st, 2020. Please upgrade your Python as Python 2.7 is no longer maintained. pip 21.0 will drop support for Python 2.7 in January 2021. More details about Python 2 support in pip can be found at https://pip.pypa.io/en/latest/development/release-process/#python-2-support pip 21.0 will remove support for this functionality.$ H; Z2 M$ S& W) S# q
Found existing installation: pyrsistent 0.17.04 @7 }9 j! ~$ I! e8 U  v% C& Z7 O0 C
Uninstalling pyrsistent-0.17.0:
( \$ b$ `5 ~* A  Would remove:3 [' a, W0 L! x: b+ y. ?4 l+ p) [
    /usr/lib64/python2.7/site-packages/_pyrsistent_version.py
4 d$ J1 N1 E: d    /usr/lib64/python2.7/site-packages/pvectorc.so* q" Z! G6 h% [% z, S) w
    /usr/lib64/python2.7/site-packages/pyrsistent-0.17.0.dist-info/*6 r2 v3 i0 @' K9 Y+ x
    /usr/lib64/python2.7/site-packages/pyrsistent/*: v4 a# K8 {9 p1 }! v
Proceed (y/n)? y
& \) I: k& c% [, e9 y; S- G* |* g  Successfully uninstalled pyrsistent-0.17.09 N% A% [$ S0 d7 }$ q# H
+ P6 a8 L6 ^5 B2 @2 `3 v

- W: p$ |" O7 x# M1 t6 R[root@controller1 ~]# pip uninstall pyrsistent. B& ]6 i/ Q( T0 Y4 j' L" M5 t# g  W
DEPRECATION: Python 2.7 reached the end of its life on January 1st, 2020. Please upgrade your Python as Python 2.7 is no longer maintained. pip 21.0 will drop support for Python 2.7 in January 2021. More details about Python 2 support in pip can be found at https://pip.pypa.io/en/latest/development/release-process/#python-2-support pip 21.0 will remove support for this functionality.
( ?: ~3 G- T1 g# z" gFound existing installation: pyrsistent 0.17.0; V$ _& Z0 e+ I6 q0 X
Uninstalling pyrsistent-0.17.0:3 t: R3 v' N$ `, g
  Would remove:
& U; L, q! f! z/ v' K4 ~! L* v3 r    /usr/lib64/python2.7/site-packages/_pyrsistent_version.py! l; j$ X5 i( l) \1 D
    /usr/lib64/python2.7/site-packages/pvectorc.so  F6 O6 _1 l( Z+ g
    /usr/lib64/python2.7/site-packages/pyrsistent-0.17.0.dist-info/*1 e) c% _( g. ~$ Q. j
    /usr/lib64/python2.7/site-packages/pyrsistent/*
. R  q+ Y9 \. j' G1 h! ?, nProceed (y/n)? y
7 s( S( O: i; R% r$ R6 P' `' \  Successfully uninstalled pyrsistent-0.17.0
4 i; F3 J" j/ G- t  w) k0 V+ R* l[root@controller1 ~]#
& |7 t. V4 L/ z) e1 T* w1 t# E[root@controller1 ~]# / X9 L0 z7 v$ w- m
[root@controller1 ~]# pip uninstall platformio
  A; C$ \- n; W; S! ^8 NDEPRECATION: Python 2.7 reached the end of its life on January 1st, 2020. Please upgrade your Python as Python 2.7 is no longer maintained. pip 21.0 will drop support for Python 2.7 in January 2021. More details about Python 2 support in pip can be found at https://pip.pypa.io/en/latest/development/release-process/#python-2-support pip 21.0 will remove support for this functionality.5 a0 b& R. T0 |; ^* y8 I
Found existing installation: platformio 5.1.1$ ?  ?# r; z' R* z  ]9 ]) x! D
Uninstalling platformio-5.1.1:6 D8 ?6 i+ X3 t) R
  Would remove:
/ P9 y; L$ q, j7 y& Y$ ]0 t    /usr/bin/pio' Q8 G$ l+ o3 w' Z; }. e
    /usr/bin/piodebuggdb) N1 ]6 o! I9 a- V# S+ {
    /usr/bin/platformio( y  D* h1 [. @8 `
    /usr/lib/python2.7/site-packages/platformio-5.1.1.dist-info/*
# @/ E- ?. W& w1 G# o$ H% Q    /usr/lib/python2.7/site-packages/platformio/*
6 j* p5 _, K$ \  V9 E$ M    /usr/lib/python2.7/site-packages/scripts/99-platformio-udev.rules
$ Z1 I3 g! A4 ^; f, @- Z) N/ N    /usr/lib/python2.7/site-packages/scripts/docspregen.py
/ f1 B( d( _, M- X/ x1 u6 \+ c( i    /usr/lib/python2.7/site-packages/scripts/fixsymlink.py
3 ]/ h  m+ R: K    /usr/lib/python2.7/site-packages/scripts/get-platformio.py+ P3 e# x1 ]; X
    /usr/lib/python2.7/site-packages/scripts/install_devplatforms.py
4 }: b# z, w; L3 U1 \+ @& z+ u) oProceed (y/n)? y9 _# }- }: W& O- {/ n) G
  Successfully uninstalled platformio-5.1.17 v2 ]3 y& P8 P: U0 t/ H
[root@controller1 ~]# pip uninstall cryptography
2 B  n' q9 x* f  A- F" F: c' WDEPRECATION: Python 2.7 reached the end of its life on January 1st, 2020. Please upgrade your Python as Python 2.7 is no longer maintained. pip 21.0 will drop support for Python 2.7 in January 2021. More details about Python 2 support in pip can be found at https://pip.pypa.io/en/latest/development/release-process/#python-2-support pip 21.0 will remove support for this functionality." U8 s3 B) B3 ]$ d7 {- I1 e
Found existing installation: cryptography 3.3.2
' w5 e0 @1 E, v1 S6 Z; OUninstalling cryptography-3.3.2:
4 G! x7 B/ I9 M% b$ ]' n6 [  Would remove:2 w/ y; \' Q5 B4 R  Y' l
    /usr/lib64/python2.7/site-packages/cryptography-3.3.2.dist-info/*. ^$ U  k5 V1 ~2 p+ [) e% t0 L
    /usr/lib64/python2.7/site-packages/cryptography/*
4 l$ }+ S% s' u  Would not remove (might be manually added):
  J* Q  \* S( [. ?    /usr/lib64/python2.7/site-packages/cryptography/hazmat/backends/commoncrypto/__init__.py
% L( g# [- {5 W9 l9 v    /usr/lib64/python2.7/site-packages/cryptography/hazmat/backends/commoncrypto/__init__.pyo
' j3 q$ }6 C0 B" j    /usr/lib64/python2.7/site-packages/cryptography/hazmat/backends/commoncrypto/backend.py4 b) B; a+ C3 D& c% A
    /usr/lib64/python2.7/site-packages/cryptography/hazmat/backends/commoncrypto/backend.pyo3 z0 k# f7 S  }5 }/ q
    /usr/lib64/python2.7/site-packages/cryptography/hazmat/backends/commoncrypto/ciphers.py6 S/ p; V) B# X& f! i  k
    /usr/lib64/python2.7/site-packages/cryptography/hazmat/backends/commoncrypto/ciphers.pyo
5 O- `7 M. ~. O% T1 U    /usr/lib64/python2.7/site-packages/cryptography/hazmat/backends/commoncrypto/hashes.py
, y% o; n3 Q% [2 ^* J" ]    /usr/lib64/python2.7/site-packages/cryptography/hazmat/backends/commoncrypto/hashes.pyo! L  y) _- y4 t7 Y4 \' w9 X9 I
    /usr/lib64/python2.7/site-packages/cryptography/hazmat/backends/commoncrypto/hmac.py
2 o4 m; O7 c) K6 [2 X    /usr/lib64/python2.7/site-packages/cryptography/hazmat/backends/commoncrypto/hmac.pyo
' n3 b0 @+ S: F# M% t7 o    /usr/lib64/python2.7/site-packages/cryptography/hazmat/backends/multibackend.py& i9 c0 a# `7 Z! H/ W+ E
    /usr/lib64/python2.7/site-packages/cryptography/hazmat/backends/multibackend.pyo% b' p4 j6 z+ s: F  p! c2 i
    /usr/lib64/python2.7/site-packages/cryptography/hazmat/bindings/_constant_time.so
" ?/ s1 O( \- ]    /usr/lib64/python2.7/site-packages/cryptography/hazmat/bindings/commoncrypto/__init__.py% Y  i2 N/ q; C; C% G, A) q
    /usr/lib64/python2.7/site-packages/cryptography/hazmat/bindings/commoncrypto/__init__.pyo+ z- o2 h/ |' h+ Z
    /usr/lib64/python2.7/site-packages/cryptography/hazmat/bindings/commoncrypto/binding.py, u1 r, A- S- N
    /usr/lib64/python2.7/site-packages/cryptography/hazmat/bindings/commoncrypto/binding.pyo5 B5 X4 i$ V$ N" O9 E
    /usr/lib64/python2.7/site-packages/cryptography/hazmat/primitives/interfaces/__init__.py
2 ?( c5 E7 p/ S3 W/ L, q    /usr/lib64/python2.7/site-packages/cryptography/hazmat/primitives/interfaces/__init__.pyo) ]5 l7 L3 p6 y
    /usr/lib64/python2.7/site-packages/cryptography/hazmat/primitives/serialization.py& u* e7 @# e1 S, w3 {& Y
    /usr/lib64/python2.7/site-packages/cryptography/hazmat/primitives/serialization.pyo) g) M! {1 g! _# W
Proceed (y/n)? y
1 G& S: b- a* h! g* d  Successfully uninstalled cryptography-3.3.21 H- f0 V1 G& f5 q
8 b# l! k' A3 Q- F7 m7 \

, s1 ^/ i9 j2 Z
 楼主| 发表于 2021-9-8 15:04:34 | 显示全部楼层
[root@controller1 ~]# pip uninstall cryptography) t& m4 l7 k6 s7 t: D3 r
DEPRECATION: Python 2.7 reached the end of its life on January 1st, 2020. Please upgrade your Python as Python 2.7 is no longer maintained. pip 21.0 will drop support for Python 2.7 in January 2021. More details about Python 2 support in pip can be found at https://pip.pypa.io/en/latest/development/release-process/#python-2-support pip 21.0 will remove support for this functionality.
- W. U( K8 E) x- y; xFound existing installation: cryptography 3.3.2
; a& t: {! e! ~7 w3 K) ?Uninstalling cryptography-3.3.2:
4 p0 u2 j% t4 A. P# V& s# S; `, e  Would remove:2 B3 X# q2 X3 R* M
    /usr/lib64/python2.7/site-packages/cryptography-3.3.2.dist-info/*
7 D& G' A& n3 O1 B    /usr/lib64/python2.7/site-packages/cryptography/*2 C% m, c  \  c0 f# S7 w  J
  Would not remove (might be manually added):: m' z: r6 r( ?- J( M
    /usr/lib64/python2.7/site-packages/cryptography/hazmat/backends/commoncrypto/__init__.py2 G4 }4 O, A! K1 L4 w
    /usr/lib64/python2.7/site-packages/cryptography/hazmat/backends/commoncrypto/__init__.pyo
1 E6 o- S+ O: U- G    /usr/lib64/python2.7/site-packages/cryptography/hazmat/backends/commoncrypto/backend.py" X% m7 f% M" H) h0 L& D
    /usr/lib64/python2.7/site-packages/cryptography/hazmat/backends/commoncrypto/backend.pyo0 h; E5 W4 C0 F! C
    /usr/lib64/python2.7/site-packages/cryptography/hazmat/backends/commoncrypto/ciphers.py; P6 q+ {- G: P: N) P/ u9 x
    /usr/lib64/python2.7/site-packages/cryptography/hazmat/backends/commoncrypto/ciphers.pyo3 M3 L+ m: S8 m  Z1 P$ Y' K6 |
    /usr/lib64/python2.7/site-packages/cryptography/hazmat/backends/commoncrypto/hashes.py1 y' A6 i8 {, _" k
    /usr/lib64/python2.7/site-packages/cryptography/hazmat/backends/commoncrypto/hashes.pyo6 o, y% ^+ g0 ^0 x$ |) P  x
    /usr/lib64/python2.7/site-packages/cryptography/hazmat/backends/commoncrypto/hmac.py/ w4 ]# @5 y& M8 q
    /usr/lib64/python2.7/site-packages/cryptography/hazmat/backends/commoncrypto/hmac.pyo0 ~9 }' [; T5 J
    /usr/lib64/python2.7/site-packages/cryptography/hazmat/backends/multibackend.py6 y: N1 U% h5 l" l
    /usr/lib64/python2.7/site-packages/cryptography/hazmat/backends/multibackend.pyo
! l6 ^& F0 H8 a! C' y" L    /usr/lib64/python2.7/site-packages/cryptography/hazmat/bindings/_constant_time.so
5 O# N9 P5 }! q5 l    /usr/lib64/python2.7/site-packages/cryptography/hazmat/bindings/commoncrypto/__init__.py
2 q( g/ w  U/ {" j7 q* ^( U    /usr/lib64/python2.7/site-packages/cryptography/hazmat/bindings/commoncrypto/__init__.pyo
' J+ u: ?: ]7 {0 f    /usr/lib64/python2.7/site-packages/cryptography/hazmat/bindings/commoncrypto/binding.py
3 k: ]! d& {* w! }; O. ?# f( }' R  N    /usr/lib64/python2.7/site-packages/cryptography/hazmat/bindings/commoncrypto/binding.pyo" e8 p/ a. n: V$ v( p" w
    /usr/lib64/python2.7/site-packages/cryptography/hazmat/primitives/interfaces/__init__.py
& h1 L8 w; _/ e. x' _    /usr/lib64/python2.7/site-packages/cryptography/hazmat/primitives/interfaces/__init__.pyo9 q9 g9 J9 z( y
    /usr/lib64/python2.7/site-packages/cryptography/hazmat/primitives/serialization.py
9 ~9 s4 S7 G$ J$ ?: d5 N    /usr/lib64/python2.7/site-packages/cryptography/hazmat/primitives/serialization.pyo
+ T( C$ A2 G: B/ q% C5 UProceed (y/n)? y
  @, J; ~2 W: C& H! s, v" p  Successfully uninstalled cryptography-3.3.2
( f+ ~# {: {% H3 }: o, Y! ?[root@controller1 ~]# rpm -qa |grep python2-cryptography: |8 y. [7 G$ l5 \' j+ p9 [( t; t' g: Z
python2-cryptography-1.7.2-2.el7.x86_64, T+ N7 {: z' k" x1 u  F9 o$ M7 K
[root@controller1 ~]# rpm -e python2-cryptography-1.7.2-2.el7.x86_64
5 p; u  K% c. R4 o$ nwarning: file /usr/lib64/python2.7/site-packages/cryptography/x509/oid.pyo: remove failed: No such file or directory( e- ^# o; D- N, `
warning: file /usr/lib64/python2.7/site-packages/cryptography/x509/oid.pyc: remove failed: No such file or directory
  C4 r* I) h6 o' a( E" E8 Z* Jwarning: file /usr/lib64/python2.7/site-packages/cryptography/x509/oid.py: remove failed: No such file or directory
  b! O2 `1 I6 C7 P: `2 R& Dwarning: file /usr/lib64/python2.7/site-packages/cryptography/x509/name.pyo: remove failed: No such file or directory
/ _) ~  j* i. |warning: file /usr/lib64/python2.7/site-packages/cryptography/x509/name.pyc: remove failed: No such file or directory
7 x. i$ X% U( z9 ?) B# Jwarning: file /usr/lib64/python2.7/site-packages/cryptography/x509/name.py: remove failed: No such file or directory  |% _- Z0 Y; ?% V! [! v4 h
warning: file /usr/lib64/python2.7/site-packages/cryptography/x509/general_name.pyo: remove failed: No such file or directory
/ Z# ]$ @: L* R2 M* Z3 cwarning: file /usr/lib64/python2.7/site-packages/cryptography/x509/general_name.pyc: remove failed: No such file or directory
/ `/ h0 _2 G2 m) Q5 V" E7 Wwarning: file /usr/lib64/python2.7/site-packages/cryptography/x509/general_name.py: remove failed: No such file or directory' N5 ?% r( i7 [: r
warning: file /usr/lib64/python2.7/site-packages/cryptography/x509/extensions.pyo: remove failed: No such file or directory$ u1 p" n' D" z: J  W9 _7 a
warning: file /usr/lib64/python2.7/site-packages/cryptography/x509/extensions.pyc: remove failed: No such file or directory
! F, ?' V6 s: K4 d, g  N' ^0 B! iwarning: file /usr/lib64/python2.7/site-packages/cryptography/x509/extensions.py: remove failed: No such file or directory
& e7 j$ ?2 ~2 I# P% _warning: file /usr/lib64/python2.7/site-packages/cryptography/x509/base.pyo: remove failed: No such file or directory) X% T1 h- T% A6 ^$ }0 q" b
warning: file /usr/lib64/python2.7/site-packages/cryptography/x509/base.pyc: remove failed: No such file or directory. {* u0 n) d/ ^# B
warning: file /usr/lib64/python2.7/site-packages/cryptography/x509/base.py: remove failed: No such file or directory
# z, K( `9 x" U" |. Pwarning: file /usr/lib64/python2.7/site-packages/cryptography/x509/__init__.pyo: remove failed: No such file or directory* U, u0 {, a, r( X0 B
warning: file /usr/lib64/python2.7/site-packages/cryptography/x509/__init__.pyc: remove failed: No such file or directory
7 |' U; e5 i# hwarning: file /usr/lib64/python2.7/site-packages/cryptography/x509/__init__.py: remove failed: No such file or directory) p( y* W- m4 \# K8 Z+ u( r- E
warning: file /usr/lib64/python2.7/site-packages/cryptography/x509: remove failed: No such file or directory
/ A# h5 N; L1 c( W) \/ |7 gwarning: file /usr/lib64/python2.7/site-packages/cryptography/utils.pyo: remove failed: No such file or directory, |" N, Y0 {; y. @
warning: file /usr/lib64/python2.7/site-packages/cryptography/utils.pyc: remove failed: No such file or directory1 L+ d) M# u; J7 s
warning: file /usr/lib64/python2.7/site-packages/cryptography/utils.py: remove failed: No such file or directory
2 Z0 ]2 e3 G/ twarning: file /usr/lib64/python2.7/site-packages/cryptography/hazmat/primitives/twofactor/utils.pyo: remove failed: No such file or directory
2 f  B# s5 F! twarning: file /usr/lib64/python2.7/site-packages/cryptography/hazmat/primitives/twofactor/utils.pyc: remove failed: No such file or directory5 _( o/ v, f* s6 w
warning: file /usr/lib64/python2.7/site-packages/cryptography/hazmat/primitives/twofactor/utils.py: remove failed: No such file or directory
% `9 K9 S9 |1 a4 i0 {5 J5 Pwarning: file /usr/lib64/python2.7/site-packages/cryptography/hazmat/primitives/twofactor/totp.pyo: remove failed: No such file or directory% _  H$ W6 m9 K
warning: file /usr/lib64/python2.7/site-packages/cryptography/hazmat/primitives/twofactor/totp.pyc: remove failed: No such file or directory5 V+ h3 J$ T1 I, C  D% E1 Q
warning: file /usr/lib64/python2.7/site-packages/cryptography/hazmat/primitives/twofactor/totp.py: remove failed: No such file or directory* ]8 m9 g% D* Z8 J% l
warning: file /usr/lib64/python2.7/site-packages/cryptography/hazmat/primitives/twofactor/hotp.pyo: remove failed: No such file or directory) U5 s( B5 K$ ?: [- T$ W
warning: file /usr/lib64/python2.7/site-packages/cryptography/hazmat/primitives/twofactor/hotp.pyc: remove failed: No such file or directory
5 Z0 b7 E- H7 C" @' _warning: file /usr/lib64/python2.7/site-packages/cryptography/hazmat/primitives/twofactor/hotp.py: remove failed: No such file or directory6 R" `, s9 e, H' j+ O
warning: file /usr/lib64/python2.7/site-packages/cryptography/hazmat/primitives/twofactor/__init__.pyo: remove failed: No such file or directory
# `( ?! _. V, X  C) c- ~' E7 `warning: file /usr/lib64/python2.7/site-packages/cryptography/hazmat/primitives/twofactor/__init__.pyc: remove failed: No such file or directory
+ l4 m  K- b! C0 G) S' f) X$ wwarning: file /usr/lib64/python2.7/site-packages/cryptography/hazmat/primitives/twofactor/__init__.py: remove failed: No such file or directory
6 p* |5 Z" `# P# F! O: Dwarning: file /usr/lib64/python2.7/site-packages/cryptography/hazmat/primitives/twofactor: remove failed: No such file or directory
& M2 _3 \, D# I( e( g% h0 @warning: file /usr/lib64/python2.7/site-packages/cryptography/hazmat/primitives/padding.pyo: remove failed: No such file or directory/ s4 ?' `0 A! v% S, Y  E
warning: file /usr/lib64/python2.7/site-packages/cryptography/hazmat/primitives/padding.pyc: remove failed: No such file or directory
% X. j( M/ L4 ]6 M. ^warning: file /usr/lib64/python2.7/site-packages/cryptography/hazmat/primitives/padding.py: remove failed: No such file or directory! T" M1 n, Q9 |
warning: file /usr/lib64/python2.7/site-packages/cryptography/hazmat/primitives/keywrap.pyo: remove failed: No such file or directory
, k1 m6 C' ]6 Z/ h3 fwarning: file /usr/lib64/python2.7/site-packages/cryptography/hazmat/primitives/keywrap.pyc: remove failed: No such file or directory+ d9 O- v+ U0 \1 A2 t, d
warning: file /usr/lib64/python2.7/site-packages/cryptography/hazmat/primitives/keywrap.py: remove failed: No such file or directory2 M/ ^. f" H  u5 v% p5 L) R
warning: file /usr/lib64/python2.7/site-packages/cryptography/hazmat/primitives/kdf/x963kdf.pyo: remove failed: No such file or directory$ n2 d2 W  i) S. Z' ^
warning: file /usr/lib64/python2.7/site-packages/cryptography/hazmat/primitives/kdf/x963kdf.pyc: remove failed: No such file or directory
2 w9 u) ~( w# ]/ y2 rwarning: file /usr/lib64/python2.7/site-packages/cryptography/hazmat/primitives/kdf/x963kdf.py: remove failed: No such file or directory
8 N2 P/ B4 ~3 T4 J1 _warning: file /usr/lib64/python2.7/site-packages/cryptography/hazmat/primitives/kdf/scrypt.pyo: remove failed: No such file or directory
* m7 z3 K2 {0 o* J" Y3 d4 ~& pwarning: file /usr/lib64/python2.7/site-packages/cryptography/hazmat/primitives/kdf/scrypt.pyc: remove failed: No such file or directory
; O, G6 \7 u8 l! Mwarning: file /usr/lib64/python2.7/site-packages/cryptography/hazmat/primitives/kdf/scrypt.py: remove failed: No such file or directory
  ~9 k+ A4 T( M( Y  Hwarning: file /usr/lib64/python2.7/site-packages/cryptography/hazmat/primitives/kdf/pbkdf2.pyo: remove failed: No such file or directory8 P8 }9 M9 P! g# v/ J
warning: file /usr/lib64/python2.7/site-packages/cryptography/hazmat/primitives/kdf/pbkdf2.pyc: remove failed: No such file or directory
( _& u, }# v. U4 `5 p2 Z/ \$ owarning: file /usr/lib64/python2.7/site-packages/cryptography/hazmat/primitives/kdf/pbkdf2.py: remove failed: No such file or directory7 X" W5 D1 b3 \: z
warning: file /usr/lib64/python2.7/site-packages/cryptography/hazmat/primitives/kdf/kbkdf.pyo: remove failed: No such file or directory$ P1 j, V' `7 y& j5 M+ d
warning: file /usr/lib64/python2.7/site-packages/cryptography/hazmat/primitives/kdf/kbkdf.pyc: remove failed: No such file or directory
9 D1 s: G9 Y$ |, wwarning: file /usr/lib64/python2.7/site-packages/cryptography/hazmat/primitives/kdf/kbkdf.py: remove failed: No such file or directory
: K. L+ G; }! \( l+ H; m8 Awarning: file /usr/lib64/python2.7/site-packages/cryptography/hazmat/primitives/kdf/hkdf.pyo: remove failed: No such file or directory
9 F' F# w- o$ Q* U8 U) Owarning: file /usr/lib64/python2.7/site-packages/cryptography/hazmat/primitives/kdf/hkdf.pyc: remove failed: No such file or directory7 _+ o  |4 z3 i& h) S
warning: file /usr/lib64/python2.7/site-packages/cryptography/hazmat/primitives/kdf/hkdf.py: remove failed: No such file or directory
9 k0 V) O' f5 V1 c! W+ W4 ewarning: file /usr/lib64/python2.7/site-packages/cryptography/hazmat/primitives/kdf/concatkdf.pyo: remove failed: No such file or directory
/ A7 R) [. p" ^6 |: [! mwarning: file /usr/lib64/python2.7/site-packages/cryptography/hazmat/primitives/kdf/concatkdf.pyc: remove failed: No such file or directory
, {. {4 t" R3 L5 k0 Jwarning: file /usr/lib64/python2.7/site-packages/cryptography/hazmat/primitives/kdf/concatkdf.py: remove failed: No such file or directory( A! o2 T8 E# F9 G0 n) O1 t
warning: file /usr/lib64/python2.7/site-packages/cryptography/hazmat/primitives/kdf/__init__.pyo: remove failed: No such file or directory
, \9 T7 _( ?" G/ vwarning: file /usr/lib64/python2.7/site-packages/cryptography/hazmat/primitives/kdf/__init__.pyc: remove failed: No such file or directory
/ L: q, P  T0 l. Ewarning: file /usr/lib64/python2.7/site-packages/cryptography/hazmat/primitives/kdf/__init__.py: remove failed: No such file or directory
- H2 b# c! e7 x0 @warning: file /usr/lib64/python2.7/site-packages/cryptography/hazmat/primitives/kdf: remove failed: No such file or directory
  M& L0 [6 n* {# S" {warning: file /usr/lib64/python2.7/site-packages/cryptography/hazmat/primitives/hmac.pyo: remove failed: No such file or directory
3 S$ S' P3 a' L$ _warning: file /usr/lib64/python2.7/site-packages/cryptography/hazmat/primitives/hmac.pyc: remove failed: No such file or directory8 B7 |# h4 `9 v9 P1 ]$ K0 t
warning: file /usr/lib64/python2.7/site-packages/cryptography/hazmat/primitives/hmac.py: remove failed: No such file or directory
! v# R, [- {, e+ R1 m. l" |$ c/ Jwarning: file /usr/lib64/python2.7/site-packages/cryptography/hazmat/primitives/hashes.pyo: remove failed: No such file or directory
! G0 y. a( Q& w: M6 n- twarning: file /usr/lib64/python2.7/site-packages/cryptography/hazmat/primitives/hashes.pyc: remove failed: No such file or directory" E; g3 d! w& \9 \# k+ M! H' g
warning: file /usr/lib64/python2.7/site-packages/cryptography/hazmat/primitives/hashes.py: remove failed: No such file or directory5 m' Q4 Y- O, \8 G
warning: file /usr/lib64/python2.7/site-packages/cryptography/hazmat/primitives/constant_time.pyo: remove failed: No such file or directory) j: n- Z: [( L) i' V
warning: file /usr/lib64/python2.7/site-packages/cryptography/hazmat/primitives/constant_time.pyc: remove failed: No such file or directory
3 O% o0 i& a2 |4 R& N4 v) Kwarning: file /usr/lib64/python2.7/site-packages/cryptography/hazmat/primitives/constant_time.py: remove failed: No such file or directory
2 A& @8 m0 }$ F. ~% n9 ewarning: file /usr/lib64/python2.7/site-packages/cryptography/hazmat/primitives/cmac.pyo: remove failed: No such file or directory$ D( u( G" s; O
warning: file /usr/lib64/python2.7/site-packages/cryptography/hazmat/primitives/cmac.pyc: remove failed: No such file or directory( ~( A' G6 n+ _, E+ `  p+ a+ i, d
warning: file /usr/lib64/python2.7/site-packages/cryptography/hazmat/primitives/cmac.py: remove failed: No such file or directory) K7 M+ p7 e# ]& d, Y
warning: file /usr/lib64/python2.7/site-packages/cryptography/hazmat/primitives/ciphers/modes.pyo: remove failed: No such file or directory# B( {# u- y. ?' a9 ^) J. u2 ]
warning: file /usr/lib64/python2.7/site-packages/cryptography/hazmat/primitives/ciphers/modes.pyc: remove failed: No such file or directory% n( q3 P( ^. ^3 s
warning: file /usr/lib64/python2.7/site-packages/cryptography/hazmat/primitives/ciphers/modes.py: remove failed: No such file or directory- U! U3 W, F* P8 f$ x
warning: file /usr/lib64/python2.7/site-packages/cryptography/hazmat/primitives/ciphers/base.pyo: remove failed: No such file or directory
5 e  l3 P+ d9 N- M# |  L3 u0 uwarning: file /usr/lib64/python2.7/site-packages/cryptography/hazmat/primitives/ciphers/base.pyc: remove failed: No such file or directory2 p7 J' _1 C7 `; ]' U8 ?2 i4 v
warning: file /usr/lib64/python2.7/site-packages/cryptography/hazmat/primitives/ciphers/base.py: remove failed: No such file or directory
3 D7 s6 R: l3 R, y- _6 r% uwarning: file /usr/lib64/python2.7/site-packages/cryptography/hazmat/primitives/ciphers/algorithms.pyo: remove failed: No such file or directory5 b, ^4 i  F( U
warning: file /usr/lib64/python2.7/site-packages/cryptography/hazmat/primitives/ciphers/algorithms.pyc: remove failed: No such file or directory# D: N' v8 H! Y  G
warning: file /usr/lib64/python2.7/site-packages/cryptography/hazmat/primitives/ciphers/algorithms.py: remove failed: No such file or directory
1 o) _# Y9 b, ~7 b' |9 Gwarning: file /usr/lib64/python2.7/site-packages/cryptography/hazmat/primitives/ciphers/__init__.pyo: remove failed: No such file or directory; f; T2 c- O8 F% N% H3 N: s' I
warning: file /usr/lib64/python2.7/site-packages/cryptography/hazmat/primitives/ciphers/__init__.pyc: remove failed: No such file or directory4 ]. ]- K/ _9 ^, q6 G( X1 S
warning: file /usr/lib64/python2.7/site-packages/cryptography/hazmat/primitives/ciphers/__init__.py: remove failed: No such file or directory  q) n: i* s- l! M7 h: X- N
warning: file /usr/lib64/python2.7/site-packages/cryptography/hazmat/primitives/ciphers: remove failed: No such file or directory
  c* n" s0 {$ H! N; ewarning: file /usr/lib64/python2.7/site-packages/cryptography/hazmat/primitives/asymmetric/utils.pyo: remove failed: No such file or directory% H% K" |, z7 C* F% r
warning: file /usr/lib64/python2.7/site-packages/cryptography/hazmat/primitives/asymmetric/utils.pyc: remove failed: No such file or directory' Q0 E* V1 o/ R6 T' K) N% M
warning: file /usr/lib64/python2.7/site-packages/cryptography/hazmat/primitives/asymmetric/utils.py: remove failed: No such file or directory6 T+ L) ?% F3 }, _% d3 h% |1 ]
warning: file /usr/lib64/python2.7/site-packages/cryptography/hazmat/primitives/asymmetric/rsa.pyo: remove failed: No such file or directory
& u  ]& S$ m4 @3 Wwarning: file /usr/lib64/python2.7/site-packages/cryptography/hazmat/primitives/asymmetric/rsa.pyc: remove failed: No such file or directory
8 L% n- P/ G) b/ M# ?warning: file /usr/lib64/python2.7/site-packages/cryptography/hazmat/primitives/asymmetric/rsa.py: remove failed: No such file or directory
3 t  j3 M% ]% e4 D$ H+ z' gwarning: file /usr/lib64/python2.7/site-packages/cryptography/hazmat/primitives/asymmetric/padding.pyo: remove failed: No such file or directory
- j( F0 v. x7 ^8 ewarning: file /usr/lib64/python2.7/site-packages/cryptography/hazmat/primitives/asymmetric/padding.pyc: remove failed: No such file or directory
7 r2 g4 F! _# N. E7 Uwarning: file /usr/lib64/python2.7/site-packages/cryptography/hazmat/primitives/asymmetric/padding.py: remove failed: No such file or directory; r( A, j  o) i
warning: file /usr/lib64/python2.7/site-packages/cryptography/hazmat/primitives/asymmetric/ec.pyo: remove failed: No such file or directory
5 x- L" k, k  a9 N( N2 `- Dwarning: file /usr/lib64/python2.7/site-packages/cryptography/hazmat/primitives/asymmetric/ec.pyc: remove failed: No such file or directory2 z+ \; p2 C7 T- _" e
warning: file /usr/lib64/python2.7/site-packages/cryptography/hazmat/primitives/asymmetric/ec.py: remove failed: No such file or directory
' R! {+ f+ Y  l" C  b+ Twarning: file /usr/lib64/python2.7/site-packages/cryptography/hazmat/primitives/asymmetric/dsa.pyo: remove failed: No such file or directory
; \2 k( z4 C, C' {( Swarning: file /usr/lib64/python2.7/site-packages/cryptography/hazmat/primitives/asymmetric/dsa.pyc: remove failed: No such file or directory
/ o. e+ ~2 s, V( V( q* Xwarning: file /usr/lib64/python2.7/site-packages/cryptography/hazmat/primitives/asymmetric/dsa.py: remove failed: No such file or directory1 v2 a. `* G9 W; R- U8 R$ A7 F' R
warning: file /usr/lib64/python2.7/site-packages/cryptography/hazmat/primitives/asymmetric/dh.pyo: remove failed: No such file or directory; x. ~, l6 K% F2 e
warning: file /usr/lib64/python2.7/site-packages/cryptography/hazmat/primitives/asymmetric/dh.pyc: remove failed: No such file or directory
; a  L# _( _) Hwarning: file /usr/lib64/python2.7/site-packages/cryptography/hazmat/primitives/asymmetric/dh.py: remove failed: No such file or directory
* A& J) j, H# ~* C. u% o1 k6 uwarning: file /usr/lib64/python2.7/site-packages/cryptography/hazmat/primitives/asymmetric/__init__.pyo: remove failed: No such file or directory! Q& V. W: ^( J) d# V% ]" V8 v- M/ V% R
warning: file /usr/lib64/python2.7/site-packages/cryptography/hazmat/primitives/asymmetric/__init__.pyc: remove failed: No such file or directory  i2 p1 k$ x$ f7 k3 {
warning: file /usr/lib64/python2.7/site-packages/cryptography/hazmat/primitives/asymmetric/__init__.py: remove failed: No such file or directory
) Z8 c$ k  Y' F1 K  b3 qwarning: file /usr/lib64/python2.7/site-packages/cryptography/hazmat/primitives/asymmetric: remove failed: No such file or directory
& _/ v+ ]) x( k  owarning: file /usr/lib64/python2.7/site-packages/cryptography/hazmat/primitives/__init__.pyo: remove failed: No such file or directory; V- b7 m6 @) f% {" Y8 O
warning: file /usr/lib64/python2.7/site-packages/cryptography/hazmat/primitives/__init__.pyc: remove failed: No such file or directory
& h6 o' M, G3 ]' W4 Twarning: file /usr/lib64/python2.7/site-packages/cryptography/hazmat/primitives/__init__.py: remove failed: No such file or directory
3 i- K  S9 v) w" A$ p* i7 O6 ?6 Uwarning: file /usr/lib64/python2.7/site-packages/cryptography/hazmat/bindings/openssl/binding.pyo: remove failed: No such file or directory0 ]# q3 w1 A' _, O5 l1 Q
warning: file /usr/lib64/python2.7/site-packages/cryptography/hazmat/bindings/openssl/binding.pyc: remove failed: No such file or directory, n" D- V& B+ o
warning: file /usr/lib64/python2.7/site-packages/cryptography/hazmat/bindings/openssl/binding.py: remove failed: No such file or directory4 G! ~8 Y! A2 o  i/ r
warning: file /usr/lib64/python2.7/site-packages/cryptography/hazmat/bindings/openssl/_conditional.pyo: remove failed: No such file or directory, H& r& U" E9 y4 R0 P
warning: file /usr/lib64/python2.7/site-packages/cryptography/hazmat/bindings/openssl/_conditional.pyc: remove failed: No such file or directory3 Q+ _  d8 s4 w2 Z. Q/ F
warning: file /usr/lib64/python2.7/site-packages/cryptography/hazmat/bindings/openssl/_conditional.py: remove failed: No such file or directory, O* y: `" {6 L0 b7 B
warning: file /usr/lib64/python2.7/site-packages/cryptography/hazmat/bindings/openssl/__init__.pyo: remove failed: No such file or directory+ e" ^, k; l4 G* U
warning: file /usr/lib64/python2.7/site-packages/cryptography/hazmat/bindings/openssl/__init__.pyc: remove failed: No such file or directory
8 N! L5 h7 m- U2 n+ F1 ~warning: file /usr/lib64/python2.7/site-packages/cryptography/hazmat/bindings/openssl/__init__.py: remove failed: No such file or directory
- \# Z& B: O% Z5 h" M2 wwarning: file /usr/lib64/python2.7/site-packages/cryptography/hazmat/bindings/openssl: remove failed: No such file or directory
" k& U' {  S8 f4 x1 Bwarning: file /usr/lib64/python2.7/site-packages/cryptography/hazmat/bindings/_padding.so: remove failed: No such file or directory& T% L: _9 h# B- T
warning: file /usr/lib64/python2.7/site-packages/cryptography/hazmat/bindings/_openssl.so: remove failed: No such file or directory
9 M& O0 H0 N0 m$ a* L/ b9 Twarning: file /usr/lib64/python2.7/site-packages/cryptography/hazmat/bindings/__init__.pyo: remove failed: No such file or directory
: E5 G: G4 ]: \5 Ywarning: file /usr/lib64/python2.7/site-packages/cryptography/hazmat/bindings/__init__.pyc: remove failed: No such file or directory) ?) u2 B2 h$ h# S7 ~) N
warning: file /usr/lib64/python2.7/site-packages/cryptography/hazmat/bindings/__init__.py: remove failed: No such file or directory
* H7 e& U5 x: b8 m3 z& Jwarning: file /usr/lib64/python2.7/site-packages/cryptography/hazmat/backends/openssl/x509.pyo: remove failed: No such file or directory
5 j: `6 W( r& I/ e  w0 H1 Dwarning: file /usr/lib64/python2.7/site-packages/cryptography/hazmat/backends/openssl/x509.pyc: remove failed: No such file or directory* v# r! k8 L/ _$ H
warning: file /usr/lib64/python2.7/site-packages/cryptography/hazmat/backends/openssl/x509.py: remove failed: No such file or directory
8 s, A, u' ?2 P: s( s. swarning: file /usr/lib64/python2.7/site-packages/cryptography/hazmat/backends/openssl/utils.pyo: remove failed: No such file or directory
! w, B( v' h& |+ O. X% D; R8 kwarning: file /usr/lib64/python2.7/site-packages/cryptography/hazmat/backends/openssl/utils.pyc: remove failed: No such file or directory/ P! N7 p1 \) k& _, p" F" ]
warning: file /usr/lib64/python2.7/site-packages/cryptography/hazmat/backends/openssl/utils.py: remove failed: No such file or directory
; W- c6 P# e/ j8 Swarning: file /usr/lib64/python2.7/site-packages/cryptography/hazmat/backends/openssl/rsa.pyo: remove failed: No such file or directory
) @) v# q1 B* ~6 xwarning: file /usr/lib64/python2.7/site-packages/cryptography/hazmat/backends/openssl/rsa.pyc: remove failed: No such file or directory" Z' P* I  P, A# @9 |
warning: file /usr/lib64/python2.7/site-packages/cryptography/hazmat/backends/openssl/rsa.py: remove failed: No such file or directory5 U' i: }+ k1 M& \' Q+ z0 g
warning: file /usr/lib64/python2.7/site-packages/cryptography/hazmat/backends/openssl/hmac.pyo: remove failed: No such file or directory. D! o4 s8 g) Z! Q3 y
warning: file /usr/lib64/python2.7/site-packages/cryptography/hazmat/backends/openssl/hmac.pyc: remove failed: No such file or directory- V+ ~, n  g. g6 ~
warning: file /usr/lib64/python2.7/site-packages/cryptography/hazmat/backends/openssl/hmac.py: remove failed: No such file or directory* J4 `2 g6 q% j- y
warning: file /usr/lib64/python2.7/site-packages/cryptography/hazmat/backends/openssl/hashes.pyo: remove failed: No such file or directory
0 R8 I3 M6 F. b' a  Twarning: file /usr/lib64/python2.7/site-packages/cryptography/hazmat/backends/openssl/hashes.pyc: remove failed: No such file or directory% h' L9 G& i% L* U5 @- W$ A3 d9 A
warning: file /usr/lib64/python2.7/site-packages/cryptography/hazmat/backends/openssl/hashes.py: remove failed: No such file or directory$ I' V$ I) u# E$ n7 v
warning: file /usr/lib64/python2.7/site-packages/cryptography/hazmat/backends/openssl/encode_asn1.pyo: remove failed: No such file or directory
. Q* K* i7 W% W) G" {! lwarning: file /usr/lib64/python2.7/site-packages/cryptography/hazmat/backends/openssl/encode_asn1.pyc: remove failed: No such file or directory( V. [, y- k" O% Y% B
warning: file /usr/lib64/python2.7/site-packages/cryptography/hazmat/backends/openssl/encode_asn1.py: remove failed: No such file or directory
6 h" c: d9 w$ y: ~- K$ X2 Pwarning: file /usr/lib64/python2.7/site-packages/cryptography/hazmat/backends/openssl/ec.pyo: remove failed: No such file or directory1 U7 G" F% _9 `
warning: file /usr/lib64/python2.7/site-packages/cryptography/hazmat/backends/openssl/ec.pyc: remove failed: No such file or directory
  s; a9 b( s0 ], M# l1 Kwarning: file /usr/lib64/python2.7/site-packages/cryptography/hazmat/backends/openssl/ec.py: remove failed: No such file or directory& p8 |' H+ ]1 l" N) \6 N
warning: file /usr/lib64/python2.7/site-packages/cryptography/hazmat/backends/openssl/dsa.pyo: remove failed: No such file or directory) H! V5 m4 p! `
warning: file /usr/lib64/python2.7/site-packages/cryptography/hazmat/backends/openssl/dsa.pyc: remove failed: No such file or directory
, w/ m+ K# k1 L- |6 N5 @& }1 gwarning: file /usr/lib64/python2.7/site-packages/cryptography/hazmat/backends/openssl/dsa.py: remove failed: No such file or directory9 N- n5 w+ C$ [; ^# G  P# ^
warning: file /usr/lib64/python2.7/site-packages/cryptography/hazmat/backends/openssl/dh.pyo: remove failed: No such file or directory
" J3 e) ^( j2 c- E# p4 K% cwarning: file /usr/lib64/python2.7/site-packages/cryptography/hazmat/backends/openssl/dh.pyc: remove failed: No such file or directory0 R: O0 H, _0 ]" @3 ?) v
warning: file /usr/lib64/python2.7/site-packages/cryptography/hazmat/backends/openssl/dh.py: remove failed: No such file or directory6 f0 |1 F( {; |: w2 n. m
warning: file /usr/lib64/python2.7/site-packages/cryptography/hazmat/backends/openssl/decode_asn1.pyo: remove failed: No such file or directory( p$ J( s6 V6 ^' F5 S0 `  ]
warning: file /usr/lib64/python2.7/site-packages/cryptography/hazmat/backends/openssl/decode_asn1.pyc: remove failed: No such file or directory- h3 j4 c0 w$ x& x/ m
warning: file /usr/lib64/python2.7/site-packages/cryptography/hazmat/backends/openssl/decode_asn1.py: remove failed: No such file or directory( [5 }" Y5 L: M/ I% f: U
warning: file /usr/lib64/python2.7/site-packages/cryptography/hazmat/backends/openssl/cmac.pyo: remove failed: No such file or directory8 r* r% `8 \; E4 y2 g6 `( D
warning: file /usr/lib64/python2.7/site-packages/cryptography/hazmat/backends/openssl/cmac.pyc: remove failed: No such file or directory6 i, J4 l5 o# E4 a! y# U" [
warning: file /usr/lib64/python2.7/site-packages/cryptography/hazmat/backends/openssl/cmac.py: remove failed: No such file or directory
8 s$ q; j" u6 }5 Q! U' ^5 }warning: file /usr/lib64/python2.7/site-packages/cryptography/hazmat/backends/openssl/ciphers.pyo: remove failed: No such file or directory
, u" @0 p0 E4 N, @warning: file /usr/lib64/python2.7/site-packages/cryptography/hazmat/backends/openssl/ciphers.pyc: remove failed: No such file or directory- s9 ^" Z3 H5 Y. W$ @# g4 B! A& M
warning: file /usr/lib64/python2.7/site-packages/cryptography/hazmat/backends/openssl/ciphers.py: remove failed: No such file or directory  a4 {7 _$ w+ G8 X7 M5 `3 I( K
warning: file /usr/lib64/python2.7/site-packages/cryptography/hazmat/backends/openssl/backend.pyo: remove failed: No such file or directory$ F" |, d/ `9 n& E
warning: file /usr/lib64/python2.7/site-packages/cryptography/hazmat/backends/openssl/backend.pyc: remove failed: No such file or directory; @% ]- ~$ U+ k4 o. `
warning: file /usr/lib64/python2.7/site-packages/cryptography/hazmat/backends/openssl/backend.py: remove failed: No such file or directory. Q) n, C2 L8 [- [3 y7 I4 _* n" a
warning: file /usr/lib64/python2.7/site-packages/cryptography/hazmat/backends/openssl/__init__.pyo: remove failed: No such file or directory3 {, C. N1 f+ r2 b
warning: file /usr/lib64/python2.7/site-packages/cryptography/hazmat/backends/openssl/__init__.pyc: remove failed: No such file or directory' U, q8 H, t. s
warning: file /usr/lib64/python2.7/site-packages/cryptography/hazmat/backends/openssl/__init__.py: remove failed: No such file or directory; y. i( A& |4 Q5 g/ O
warning: file /usr/lib64/python2.7/site-packages/cryptography/hazmat/backends/openssl: remove failed: No such file or directory
* C9 V8 x, G, d. W/ j- B8 Jwarning: file /usr/lib64/python2.7/site-packages/cryptography/hazmat/backends/interfaces.pyo: remove failed: No such file or directory' f) y3 S- A  K, P
warning: file /usr/lib64/python2.7/site-packages/cryptography/hazmat/backends/interfaces.pyc: remove failed: No such file or directory
4 s2 N/ N3 f- G+ p  Vwarning: file /usr/lib64/python2.7/site-packages/cryptography/hazmat/backends/interfaces.py: remove failed: No such file or directory# Y( T' t. h9 M
warning: file /usr/lib64/python2.7/site-packages/cryptography/hazmat/backends/__init__.pyo: remove failed: No such file or directory( ]9 u. h! t, y/ H! m
warning: file /usr/lib64/python2.7/site-packages/cryptography/hazmat/backends/__init__.pyc: remove failed: No such file or directory
7 d( g& Q) ~5 K2 C0 Zwarning: file /usr/lib64/python2.7/site-packages/cryptography/hazmat/backends/__init__.py: remove failed: No such file or directory  d3 j, L' n4 Y$ V8 r8 _
warning: file /usr/lib64/python2.7/site-packages/cryptography/hazmat/__init__.pyo: remove failed: No such file or directory
/ Z. _4 j& B' y9 i$ F, Mwarning: file /usr/lib64/python2.7/site-packages/cryptography/hazmat/__init__.pyc: remove failed: No such file or directory  d, P% s& }+ h& S
warning: file /usr/lib64/python2.7/site-packages/cryptography/hazmat/__init__.py: remove failed: No such file or directory
& P0 L/ H3 _) \" m: ^; Iwarning: file /usr/lib64/python2.7/site-packages/cryptography/fernet.pyo: remove failed: No such file or directory
2 ^7 B' \3 v" I& m# @* P' swarning: file /usr/lib64/python2.7/site-packages/cryptography/fernet.pyc: remove failed: No such file or directory+ f8 y, V6 o! j+ C% g
warning: file /usr/lib64/python2.7/site-packages/cryptography/fernet.py: remove failed: No such file or directory9 C. A* t: l9 Q4 @5 {" H: _+ b; X
warning: file /usr/lib64/python2.7/site-packages/cryptography/exceptions.pyo: remove failed: No such file or directory
1 H1 l/ I* {' u: T, Ewarning: file /usr/lib64/python2.7/site-packages/cryptography/exceptions.pyc: remove failed: No such file or directory# r9 U; I0 r$ Y% a
warning: file /usr/lib64/python2.7/site-packages/cryptography/exceptions.py: remove failed: No such file or directory
7 T6 t# m9 V: @' Q6 d: j. y. X- Fwarning: file /usr/lib64/python2.7/site-packages/cryptography/__init__.pyo: remove failed: No such file or directory
& }# \' D3 t. _  V+ A$ B8 q+ ^warning: file /usr/lib64/python2.7/site-packages/cryptography/__init__.pyc: remove failed: No such file or directory
/ o! u6 ~1 J2 K, V( awarning: file /usr/lib64/python2.7/site-packages/cryptography/__init__.py: remove failed: No such file or directory
6 h: S4 T) r/ H. _) j% kwarning: file /usr/lib64/python2.7/site-packages/cryptography/__about__.pyo: remove failed: No such file or directory* [9 {* r0 k# ~2 L1 |% t6 J' z  m
warning: file /usr/lib64/python2.7/site-packages/cryptography/__about__.pyc: remove failed: No such file or directory7 ~$ r9 _' K/ B' u; H7 k
warning: file /usr/lib64/python2.7/site-packages/cryptography/__about__.py: remove failed: No such file or directory1 d3 J& [  v8 u
[root@controller1 ~]# rpm -qa |grep python2-cryptography6 E1 f: C6 N1 }# b3 U

$ d! L/ E! g8 i2 z: K  E* w/ F
& b4 `+ [7 s1 v0 a& Q" @. z报好多错误:- Z6 k" N9 p; T/ M) _, @

5 j' `$ }! p: @% ]
& {' m! r$ l3 W$ N' q* s2 n继续卸载:: x) ?3 R: @% k+ ~
[root@controller1 ~]# rpm -qa|grep python2-future
6 ]/ k* S4 q0 T/ }4 }python2-future-0.18.2-2.el7.noarch0 ?' _. k! |1 R; u
[root@controller1 ~]# rpm -e python2-future-0.18.2-2.el7.noarch, w0 [- W7 [& N) a5 b

2 g' H3 Y! k: Q8 N" V6 x7 v
; M6 @: C- v- D7 D+ d, |4 @" e* l$ N  c' O

' B/ ~8 m" K9 [1 J" B7 O
 楼主| 发表于 2021-9-8 15:27:34 | 显示全部楼层
重新安装插件:  y4 x6 W1 R3 ~" S
pip install python-openstackclientpython-glanceclient python-neutronclient

; ~% u! v. z. f& o8 x
4 c+ L% W" x# f

3 @7 E- X4 B( h; {4 LRequirement already satisfied: requests>=2.14.2 in /usr/lib/python2.7/site-packages (from python-glanceclient) (2.26.0)/ b9 Q& Q1 x; t$ C9 s* ]( t" c
Requirement already satisfied: wrapt>=1.7.0 in /usr/lib64/python2.7/site-packages (from python-glanceclient) (1.12.1)1 m1 I" z# Y! J
Requirement already satisfied: PrettyTable<0.8,>=0.7.1 in /usr/lib/python2.7/site-packages (from python-glanceclient) (0.7.2)
4 q- h3 a9 b/ i: CRequirement already satisfied: warlock<2,>=1.2.0 in /usr/lib/python2.7/site-packages (from python-glanceclient) (1.3.3)  x6 ^: \" j/ s
Requirement already satisfied: oslo.log>=3.36.0 in /usr/lib/python2.7/site-packages (from python-neutronclient) (3.45.2)
+ b  X$ b- H- ?0 ARequirement already satisfied: iso8601>=0.1.11 in /usr/lib/python2.7/site-packages (from python-neutronclient) (0.1.14). H/ [5 W- f2 i. Y/ \1 |, U2 x) n
Requirement already satisfied: os-client-config>=1.28.0 in /usr/lib/python2.7/site-packages (from python-neutronclient) (2.1.0)
. ^% F' L6 f6 xRequirement already satisfied: debtcollector>=1.2.0 in /usr/lib/python2.7/site-packages (from python-neutronclient) (1.22.0)
/ @3 n) M* c* l. }Requirement already satisfied: oslo.serialization!=2.19.1,>=2.18.0 in /usr/lib/python2.7/site-packages (from python-neutronclient) (2.29.3)% y4 e( |- J- ^, R7 ~) x3 g; v
Requirement already satisfied: simplejson>=3.5.1 in /usr/lib64/python2.7/site-packages (from python-neutronclient) (3.10.0)5 G7 b  `$ Y9 }! r
Requirement already satisfied: netaddr>=0.7.18 in /usr/lib/python2.7/site-packages (from python-neutronclient) (0.8.0)
) E0 G3 t+ L* S" w. X# y( a9 wRequirement already satisfied: pytz>=2015.7 in /usr/lib/python2.7/site-packages (from Babel!=2.4.0,>=2.3.4->python-openstackclient) (2021.1)- E8 D; p1 p! \# B, @
Requirement already satisfied: stevedore>=1.20.0 in /usr/lib/python2.7/site-packages (from cliff!=2.9.0,>=2.8.0->python-openstackclient) (1.32.0)
3 U* [4 c& S; i0 ]Requirement already satisfied: pyparsing>=2.1.0 in /usr/lib/python2.7/site-packages (from cliff!=2.9.0,>=2.8.0->python-openstackclient) (2.4.7)
0 S2 d# |7 ]5 I+ h6 bRequirement already satisfied: PyYAML>=3.12 in /usr/lib64/python2.7/site-packages (from cliff!=2.9.0,>=2.8.0->python-openstackclient) (5.4.1)! R) T1 I  V6 u8 |% F  M4 G
Requirement already satisfied: cmd2!=0.8.3,<0.9.0,>=0.8.0 in /usr/lib/python2.7/site-packages (from cliff!=2.9.0,>=2.8.0->python-openstackclient) (0.8.9)
9 l4 r$ q' y$ r8 u& yRequirement already satisfied: unicodecsv>=0.8.0; python_version < "3.0" in /usr/lib/python2.7/site-packages (from cliff!=2.9.0,>=2.8.0->python-openstackclient) (0.14.1)5 n* [' P+ n4 \/ T0 f
Requirement already satisfied: futures>=3.0.0; python_version == "2.7" or python_version == "2.6" in /usr/lib/python2.7/site-packages (from openstacksdk>=0.36.0->python-openstackclient) (3.3.0)$ Z6 W+ q$ m% }- o0 h- J
Requirement already satisfied: requestsexceptions>=1.2.0 in /usr/lib/python2.7/site-packages (from openstacksdk>=0.36.0->python-openstackclient) (1.4.0)3 M5 N7 |: Z8 i% ?
Requirement already satisfied: munch>=2.1.0 in /usr/lib/python2.7/site-packages (from openstacksdk>=0.36.0->python-openstackclient) (2.5.0)( Q; V5 X- g  Z2 K  p. l
Requirement already satisfied: jmespath>=0.9.0 in /usr/lib/python2.7/site-packages (from openstacksdk>=0.36.0->python-openstackclient) (0.10.0)
: Q9 [7 i* }0 e4 g) hRequirement already satisfied: jsonpatch!=1.20,>=1.16 in /usr/lib/python2.7/site-packages (from openstacksdk>=0.36.0->python-openstackclient) (1.32)2 j5 T+ m7 E% A6 p
Requirement already satisfied: cryptography>=2.1 in /usr/lib64/python2.7/site-packages (from openstacksdk>=0.36.0->python-openstackclient) (3.3.2)7 @, Q, F4 j! F0 C2 ~7 Z5 m( P
Requirement already satisfied: decorator>=4.4.1 in /usr/lib/python2.7/site-packages (from openstacksdk>=0.36.0->python-openstackclient) (4.4.2)2 k/ a6 Y3 X, y# |: b7 @
Requirement already satisfied: dogpile.cache>=0.6.5 in /usr/lib/python2.7/site-packages (from openstacksdk>=0.36.0->python-openstackclient) (0.9.2)9 U: ~) G' G8 |$ L
Requirement already satisfied: appdirs>=1.3.0 in /usr/lib/python2.7/site-packages (from openstacksdk>=0.36.0->python-openstackclient) (1.4.4)
8 z1 X, j) h% I8 D9 kRequirement already satisfied: os-service-types>=1.7.0 in /usr/lib/python2.7/site-packages (from openstacksdk>=0.36.0->python-openstackclient) (1.7.0)9 [$ B2 U8 v# R+ l( o
Requirement already satisfied: netifaces>=0.10.4 in /usr/lib64/python2.7/site-packages (from openstacksdk>=0.36.0->python-openstackclient) (0.10.9)
$ `6 X/ N6 N  L' I9 E# y! i/ s! hRequirement already satisfied: ipaddress>=1.0.17; python_version < "3.3" in /usr/lib/python2.7/site-packages (from openstacksdk>=0.36.0->python-openstackclient) (1.0.23): s& r; N; N! W  M6 K* |  V
Requirement already satisfied: funcsigs>=1.0.0; python_version == "2.7" or python_version == "2.6" in /usr/lib/python2.7/site-packages (from oslo.utils>=3.33.0->python-openstackclient) (1.0.2)
7 \4 C$ N4 y$ t2 ORequirement already satisfied: monotonic>=0.6; python_version < "3.3" in /usr/lib/python2.7/site-packages (from oslo.utils>=3.33.0->python-openstackclient) (1.6)
2 K! G/ v# |+ B* [Requirement already satisfied: oslo.config>=5.2.0 in /usr/lib/python2.7/site-packages (from python-keystoneclient>=3.22.0->python-openstackclient) (7.0.0)3 n( N6 j& S3 r6 F2 i& }( L
Requirement already satisfied: certifi>=2017.4.17 in /usr/lib/python2.7/site-packages (from requests>=2.14.2->python-glanceclient) (2021.5.30)
" T# O1 M3 k6 t, sRequirement already satisfied: urllib3<1.27,>=1.21.1 in /usr/lib/python2.7/site-packages (from requests>=2.14.2->python-glanceclient) (1.26.6)
4 o8 F6 ~2 {* L# kRequirement already satisfied: idna<3,>=2.5; python_version < "3" in /usr/lib/python2.7/site-packages (from requests>=2.14.2->python-glanceclient) (2.10)1 h) D% V; D: n; u8 p/ B3 y
Requirement already satisfied: chardet<5,>=3.0.2; python_version < "3" in /usr/lib/python2.7/site-packages (from requests>=2.14.2->python-glanceclient) (4.0.0)
2 a" Z' r8 D! ^- ?- b. \. b5 VRequirement already satisfied: jsonschema<4,>=0.7 in /usr/lib/python2.7/site-packages (from warlock<2,>=1.2.0->python-glanceclient) (3.2.0)6 S! M( D( ]- }& `3 G/ e6 X
Requirement already satisfied: pyinotify>=0.9.6; sys_platform != "win32" and sys_platform != "darwin" and sys_platform != "sunos5" in /usr/lib/python2.7/site-packages (from oslo.log>=3.36.0->python-neutronclient) (0.9.6)( Z2 U. [# C, D& i2 n9 k) ]5 N2 R6 w
Requirement already satisfied: oslo.context>=2.20.0 in /usr/lib/python2.7/site-packages (from oslo.log>=3.36.0->python-neutronclient) (2.23.1)
% F6 L2 W1 B+ T3 B  N  o& [. }Requirement already satisfied: python-dateutil>=2.7.0 in /usr/lib/python2.7/site-packages (from oslo.log>=3.36.0->python-neutronclient) (2.8.1)
5 W4 O0 C, |' l8 u. hRequirement already satisfied: msgpack>=0.5.2 in /usr/lib/python2.7/site-packages (from oslo.serialization!=2.19.1,>=2.18.0->python-neutronclient) (1.0.2)
5 _4 A2 |% h/ m: z0 E- G2 M  b# eRequirement already satisfied: importlib-resources; python_version < "3.7" in /usr/lib/python2.7/site-packages (from netaddr>=0.7.18->python-neutronclient) (3.3.1)/ e4 O) v- P& Y9 e) V1 r$ A3 ]2 F
Requirement already satisfied: subprocess32; python_version < "3.0" in /usr/lib64/python2.7/site-packages (from cmd2!=0.8.3,<0.9.0,>=0.8.0->cliff!=2.9.0,>=2.8.0->python-openstackclient) (3.5.4)
, v0 J( u7 x$ {/ SRequirement already satisfied: contextlib2; python_version < "3.5" in /usr/lib/python2.7/site-packages (from cmd2!=0.8.3,<0.9.0,>=0.8.0->cliff!=2.9.0,>=2.8.0->python-openstackclient) (0.6.0.post1)& W+ n2 `% ~- w% {& V1 K6 r
Requirement already satisfied: enum34; python_version < "3.4" in /usr/lib/python2.7/site-packages (from cmd2!=0.8.3,<0.9.0,>=0.8.0->cliff!=2.9.0,>=2.8.0->python-openstackclient) (1.1.10)
6 w6 _! e& ]7 n4 V( w$ T' R* G; r# {6 ZRequirement already satisfied: pyperclip in /usr/lib/python2.7/site-packages (from cmd2!=0.8.3,<0.9.0,>=0.8.0->cliff!=2.9.0,>=2.8.0->python-openstackclient) (1.8.2)
1 A6 @: k3 S9 @" I2 e3 ^+ TRequirement already satisfied: wcwidth; sys_platform != "win32" in /usr/lib/python2.7/site-packages (from cmd2!=0.8.3,<0.9.0,>=0.8.0->cliff!=2.9.0,>=2.8.0->python-openstackclient) (0.2.5)& }* A: H6 p8 {- e9 p
Requirement already satisfied: jsonpointer>=1.9 in /usr/lib/python2.7/site-packages (from jsonpatch!=1.20,>=1.16->openstacksdk>=0.36.0->python-openstackclient) (2.1)0 K' U5 P: m- u& l6 W2 v
Requirement already satisfied: cffi>=1.12 in /usr/lib64/python2.7/site-packages (from cryptography>=2.1->openstacksdk>=0.36.0->python-openstackclient) (1.14.6)( m. {- O' x) a, p
Requirement already satisfied: rfc3986>=1.2.0 in /usr/lib/python2.7/site-packages (from oslo.config>=5.2.0->python-keystoneclient>=3.22.0->python-openstackclient) (1.4.0)
8 ?/ u: f" [! L6 q$ uRequirement already satisfied: setuptools in /usr/lib/python2.7/site-packages (from jsonschema<4,>=0.7->warlock<2,>=1.2.0->python-glanceclient) (44.1.1)
; ~  f; [% `# f; WRequirement already satisfied: functools32; python_version < "3" in /usr/lib/python2.7/site-packages (from jsonschema<4,>=0.7->warlock<2,>=1.2.0->python-glanceclient) (3.2.3.post2)- P/ |* ?" i, Z' h, d+ i
Requirement already satisfied: pyrsistent>=0.14.0 in /usr/lib64/python2.7/site-packages (from jsonschema<4,>=0.7->warlock<2,>=1.2.0->python-glanceclient) (0.17.0)! |3 K- X$ _0 B
Requirement already satisfied: attrs>=17.4.0 in /usr/lib/python2.7/site-packages (from jsonschema<4,>=0.7->warlock<2,>=1.2.0->python-glanceclient) (20.3.0)
+ i& ?) E7 l& X9 w; i; i# fRequirement already satisfied: importlib-metadata; python_version < "3.8" in /usr/lib/python2.7/site-packages (from jsonschema<4,>=0.7->warlock<2,>=1.2.0->python-glanceclient) (2.1.1)$ ^- l4 {/ `) e  T- v5 c# v4 X
Requirement already satisfied: singledispatch; python_version < "3.4" in /usr/lib/python2.7/site-packages (from importlib-resources; python_version < "3.7"->netaddr>=0.7.18->python-neutronclient) (3.6.1); A  Q3 J, t9 G$ N1 M! ~5 g
Requirement already satisfied: zipp>=0.4; python_version < "3.8" in /usr/lib/python2.7/site-packages (from importlib-resources; python_version < "3.7"->netaddr>=0.7.18->python-neutronclient) (1.2.0)$ [, _+ H2 q6 M. ^
Requirement already satisfied: pathlib2; python_version < "3" in /usr/lib/python2.7/site-packages (from importlib-resources; python_version < "3.7"->netaddr>=0.7.18->python-neutronclient) (2.3.5)
- _4 E# @' h2 }2 _: @: QRequirement already satisfied: typing; python_version < "3.5" in /usr/lib/python2.7/site-packages (from importlib-resources; python_version < "3.7"->netaddr>=0.7.18->python-neutronclient) (3.7.4.3)
0 _1 N) P# Y4 Z- o- pRequirement already satisfied: backports.functools-lru-cache>=1.2.1; python_version < "3.2" in /usr/lib/python2.7/site-packages (from wcwidth; sys_platform != "win32"->cmd2!=0.8.3,<0.9.0,>=0.8.0->cliff!=2.9.0,>=2.8.0->python-openstackclient) (1.6.4)
& ~; ?$ _4 t  i; IRequirement already satisfied: pycparser in /usr/lib/python2.7/site-packages (from cffi>=1.12->cryptography>=2.1->openstacksdk>=0.36.0->python-openstackclient) (2.20)
0 {8 O) G- l; B$ m  F5 f. ?- L% LRequirement already satisfied: configparser>=3.5; python_version < "3" in /usr/lib/python2.7/site-packages (from importlib-metadata; python_version < "3.8"->jsonschema<4,>=0.7->warlock<2,>=1.2.0->python-glanceclient) (4.0.2)
: Q# }, `+ S& |) @* wRequirement already satisfied: scandir; python_version < "3.5" in /usr/lib64/python2.7/site-packages (from pathlib2; python_version < "3"->importlib-resources; python_version < "3.7"->netaddr>=0.7.18->python-neutronclient) (1.10.0)/ ?9 L, Z6 r7 x0 W- o8 n" A: ]
Building wheels for collected packages: python-openstackclient
- H: V3 Y6 N4 f5 a) S  Building wheel for python-openstackclient (setup.py) ... done
. f+ L  A. N6 W$ F( D3 ]) E  Created wheel for python-openstackclient: filename=python_openstackclient-5.2.2-py2-none-any.whl size=885438 sha256=562d05241341c5dadb03a5de981ea506ee4918b3b5b7e6c415ec64f6f5ae5b55  ]4 q& A7 |# N" w) b6 T
  Stored in directory: /root/.cache/pip/wheels/92/9a/a6/bbafdfec4d13ac6dda30848301e47a6f56c0c97d83e18400a9
3 d. B' I" X* t& ]" }, bSuccessfully built python-openstackclient: A# n# F$ o8 ~5 ]; S; b
Installing collected packages: python-openstackclient, python-glanceclient, python-neutronclient4 k7 C% b  i% y. T/ J6 u5 b
Successfully installed python-glanceclient-3.0.0 python-neutronclient-7.1.0 python-openstackclient-5.2.2
/ m8 U5 Q$ H. F; r# k% ]* \[root@controller1 ~]# pip install python-openstackclient; E8 K$ a' d, `; J6 m9 z
DEPRECATION: Python 2.7 reached the end of its life on January 1st, 2020. Please upgrade your Python as Python 2.7 is no longer maintained. pip 21.0 will drop support for Python 2.7 in January 2021. More details about Python 2 support in pip can be found at https://pip.pypa.io/en/latest/development/release-process/#python-2-support pip 21.0 will remove support for this functionality.) m5 Y) u3 r# N3 D% `8 f
Looking in indexes: http://mirrors.aliyun.com/pypi/simple/; F1 H3 M# e- _7 L; O
Requirement already satisfied: python-openstackclient in /usr/lib/python2.7/site-packages (5.2.2)
3 \' F$ T% v+ _% ^9 H- tRequirement already satisfied: pbr!=2.1.0,>=2.0.0 in /usr/lib/python2.7/site-packages (from python-openstackclient) (5.5.1)5 M7 ?3 a" y0 }& c# i' ?  x5 G
Requirement already satisfied: cliff!=2.9.0,>=2.8.0 in /usr/lib/python2.7/site-packages (from python-openstackclient) (2.18.0)
0 y4 T. R1 n4 M  S. W" ARequirement already satisfied: osc-lib>=2.0.0 in /usr/lib/python2.7/site-packages (from python-openstackclient) (2.0.0)
* k- I+ c- s; e* |4 _8 W2 lRequirement already satisfied: oslo.i18n>=3.15.3 in /usr/lib/python2.7/site-packages (from python-openstackclient) (3.25.1)
' Z7 c. O+ [( w! u' jRequirement already satisfied: python-cinderclient>=3.3.0 in /usr/lib/python2.7/site-packages (from python-openstackclient) (6.0.0)
# q+ z& T$ k8 o( `1 K& WRequirement already satisfied: six>=1.10.0 in /usr/lib/python2.7/site-packages (from python-openstackclient) (1.16.0)
) h8 r% M$ ]3 k/ Y1 H2 }Requirement already satisfied: openstacksdk>=0.36.0 in /usr/lib/python2.7/site-packages (from python-openstackclient) (0.45.0)/ E0 m5 i3 Z* ?( \$ U6 S. ^7 u0 J
Requirement already satisfied: python-novaclient>=15.1.0 in /usr/lib/python2.7/site-packages (from python-openstackclient) (16.0.0)  M( v$ W* o1 _$ m8 g
Requirement already satisfied: oslo.utils>=3.33.0 in /usr/lib/python2.7/site-packages (from python-openstackclient) (3.42.1)
2 k# ]( s$ J4 }4 V9 TRequirement already satisfied: Babel!=2.4.0,>=2.3.4 in /usr/lib/python2.7/site-packages (from python-openstackclient) (2.9.0)4 B) F/ B9 N, h- i5 v8 S% w
Requirement already satisfied: python-keystoneclient>=3.22.0 in /usr/lib/python2.7/site-packages (from python-openstackclient) (3.22.0)7 b8 ^  h$ u3 j
Requirement already satisfied: stevedore>=1.20.0 in /usr/lib/python2.7/site-packages (from cliff!=2.9.0,>=2.8.0->python-openstackclient) (1.32.0)
: n; J0 [# O7 k! K- URequirement already satisfied: pyparsing>=2.1.0 in /usr/lib/python2.7/site-packages (from cliff!=2.9.0,>=2.8.0->python-openstackclient) (2.4.7)
8 V) @7 j4 }8 h  \, v* j: NRequirement already satisfied: PyYAML>=3.12 in /usr/lib64/python2.7/site-packages (from cliff!=2.9.0,>=2.8.0->python-openstackclient) (5.4.1)
0 B& v  a" [' G* T8 k0 X& Z0 |Requirement already satisfied: cmd2!=0.8.3,<0.9.0,>=0.8.0 in /usr/lib/python2.7/site-packages (from cliff!=2.9.0,>=2.8.0->python-openstackclient) (0.8.9)
8 I! P$ c3 T# ?/ Y8 rRequirement already satisfied: unicodecsv>=0.8.0; python_version < "3.0" in /usr/lib/python2.7/site-packages (from cliff!=2.9.0,>=2.8.0->python-openstackclient) (0.14.1)8 T0 M& U) u8 S7 F' y
Requirement already satisfied: PrettyTable<0.8,>=0.7.2 in /usr/lib/python2.7/site-packages (from cliff!=2.9.0,>=2.8.0->python-openstackclient) (0.7.2)! b+ A% M  @. ]5 {
Requirement already satisfied: simplejson>=3.5.1 in /usr/lib64/python2.7/site-packages (from osc-lib>=2.0.0->python-openstackclient) (3.10.0): X/ n1 C9 I1 a
Requirement already satisfied: keystoneauth1>=3.7.0 in /usr/lib/python2.7/site-packages (from osc-lib>=2.0.0->python-openstackclient) (4.0.1)
8 h2 y* p4 A7 ^: h- V( b" d- WRequirement already satisfied: requests!=2.20.0,>=2.14.2 in /usr/lib/python2.7/site-packages (from python-cinderclient>=3.3.0->python-openstackclient) (2.26.0)- y, q7 l8 C9 z' {% v; f8 m
Requirement already satisfied: futures>=3.0.0; python_version == "2.7" or python_version == "2.6" in /usr/lib/python2.7/site-packages (from openstacksdk>=0.36.0->python-openstackclient) (3.3.0)# R5 K  |2 w# A* s% w8 V: D$ I7 d0 T
Requirement already satisfied: requestsexceptions>=1.2.0 in /usr/lib/python2.7/site-packages (from openstacksdk>=0.36.0->python-openstackclient) (1.4.0): T/ V5 K4 J1 {; ?# `8 P
Requirement already satisfied: munch>=2.1.0 in /usr/lib/python2.7/site-packages (from openstacksdk>=0.36.0->python-openstackclient) (2.5.0)
1 s# b" O1 K+ ~Requirement already satisfied: jmespath>=0.9.0 in /usr/lib/python2.7/site-packages (from openstacksdk>=0.36.0->python-openstackclient) (0.10.0)+ Q% x$ B0 m" K+ Z" d
Requirement already satisfied: iso8601>=0.1.11 in /usr/lib/python2.7/site-packages (from openstacksdk>=0.36.0->python-openstackclient) (0.1.14)
' [" q$ c9 e( sRequirement already satisfied: jsonpatch!=1.20,>=1.16 in /usr/lib/python2.7/site-packages (from openstacksdk>=0.36.0->python-openstackclient) (1.32)
, f. l( o6 m5 X& DRequirement already satisfied: cryptography>=2.1 in /usr/lib64/python2.7/site-packages (from openstacksdk>=0.36.0->python-openstackclient) (3.3.2)
3 H& \7 ^7 c9 nRequirement already satisfied: decorator>=4.4.1 in /usr/lib/python2.7/site-packages (from openstacksdk>=0.36.0->python-openstackclient) (4.4.2)
7 l6 k/ `+ g, z2 YRequirement already satisfied: dogpile.cache>=0.6.5 in /usr/lib/python2.7/site-packages (from openstacksdk>=0.36.0->python-openstackclient) (0.9.2)5 |& l7 h6 O: v4 t' j
Requirement already satisfied: appdirs>=1.3.0 in /usr/lib/python2.7/site-packages (from openstacksdk>=0.36.0->python-openstackclient) (1.4.4)6 u8 V! C# X3 F6 z0 Z' D  k1 r9 \- D
Requirement already satisfied: os-service-types>=1.7.0 in /usr/lib/python2.7/site-packages (from openstacksdk>=0.36.0->python-openstackclient) (1.7.0)$ [$ D8 U- B5 G
Requirement already satisfied: netifaces>=0.10.4 in /usr/lib64/python2.7/site-packages (from openstacksdk>=0.36.0->python-openstackclient) (0.10.9)
% \) g! u9 V" r- q& e+ [' h0 cRequirement already satisfied: ipaddress>=1.0.17; python_version < "3.3" in /usr/lib/python2.7/site-packages (from openstacksdk>=0.36.0->python-openstackclient) (1.0.23)
; a8 v9 q9 [2 A6 X, T6 t) ^; |% YRequirement already satisfied: oslo.serialization!=2.19.1,>=2.18.0 in /usr/lib/python2.7/site-packages (from python-novaclient>=15.1.0->python-openstackclient) (2.29.3)$ L1 }: J/ j) H" I8 n
Requirement already satisfied: funcsigs>=1.0.0; python_version == "2.7" or python_version == "2.6" in /usr/lib/python2.7/site-packages (from oslo.utils>=3.33.0->python-openstackclient) (1.0.2)
! x/ f" {+ T& B9 T! i1 |0 Y" ~9 f4 dRequirement already satisfied: pytz>=2013.6 in /usr/lib/python2.7/site-packages (from oslo.utils>=3.33.0->python-openstackclient) (2021.1)
7 p. G4 @- @3 h0 f/ oRequirement already satisfied: netaddr>=0.7.18 in /usr/lib/python2.7/site-packages (from oslo.utils>=3.33.0->python-openstackclient) (0.8.0)
* S* u9 o$ u! X6 a( RRequirement already satisfied: debtcollector>=1.2.0 in /usr/lib/python2.7/site-packages (from oslo.utils>=3.33.0->python-openstackclient) (1.22.0): c( Q% U2 u& U. o* W- e" }# o
Requirement already satisfied: monotonic>=0.6; python_version < "3.3" in /usr/lib/python2.7/site-packages (from oslo.utils>=3.33.0->python-openstackclient) (1.6)
; u6 Y1 [3 H4 ?$ m* b, sRequirement already satisfied: oslo.config>=5.2.0 in /usr/lib/python2.7/site-packages (from python-keystoneclient>=3.22.0->python-openstackclient) (7.0.0)% d- k# I7 j1 \9 F
Requirement already satisfied: subprocess32; python_version < "3.0" in /usr/lib64/python2.7/site-packages (from cmd2!=0.8.3,<0.9.0,>=0.8.0->cliff!=2.9.0,>=2.8.0->python-openstackclient) (3.5.4)
; @4 C0 I  m: Q7 E- S% R1 YRequirement already satisfied: contextlib2; python_version < "3.5" in /usr/lib/python2.7/site-packages (from cmd2!=0.8.3,<0.9.0,>=0.8.0->cliff!=2.9.0,>=2.8.0->python-openstackclient) (0.6.0.post1)% S6 {- G( {" Y6 n' I" X
Requirement already satisfied: enum34; python_version < "3.4" in /usr/lib/python2.7/site-packages (from cmd2!=0.8.3,<0.9.0,>=0.8.0->cliff!=2.9.0,>=2.8.0->python-openstackclient) (1.1.10)
* ]  Z  n! a7 m) X% J$ z' DRequirement already satisfied: pyperclip in /usr/lib/python2.7/site-packages (from cmd2!=0.8.3,<0.9.0,>=0.8.0->cliff!=2.9.0,>=2.8.0->python-openstackclient) (1.8.2)
+ v- M- ?. m" B" MRequirement already satisfied: wcwidth; sys_platform != "win32" in /usr/lib/python2.7/site-packages (from cmd2!=0.8.3,<0.9.0,>=0.8.0->cliff!=2.9.0,>=2.8.0->python-openstackclient) (0.2.5)
0 l$ O( ?* i9 ~1 J# r( M1 nRequirement already satisfied: certifi>=2017.4.17 in /usr/lib/python2.7/site-packages (from requests!=2.20.0,>=2.14.2->python-cinderclient>=3.3.0->python-openstackclient) (2021.5.30)
& m9 r3 N9 v4 V1 }3 |! a1 JRequirement already satisfied: urllib3<1.27,>=1.21.1 in /usr/lib/python2.7/site-packages (from requests!=2.20.0,>=2.14.2->python-cinderclient>=3.3.0->python-openstackclient) (1.26.6)
$ `- p5 N0 W. ERequirement already satisfied: idna<3,>=2.5; python_version < "3" in /usr/lib/python2.7/site-packages (from requests!=2.20.0,>=2.14.2->python-cinderclient>=3.3.0->python-openstackclient) (2.10)/ D/ R3 ^& B: h1 y. B  i; ?
Requirement already satisfied: chardet<5,>=3.0.2; python_version < "3" in /usr/lib/python2.7/site-packages (from requests!=2.20.0,>=2.14.2->python-cinderclient>=3.3.0->python-openstackclient) (4.0.0)7 B- R! N3 _9 X3 t
Requirement already satisfied: jsonpointer>=1.9 in /usr/lib/python2.7/site-packages (from jsonpatch!=1.20,>=1.16->openstacksdk>=0.36.0->python-openstackclient) (2.1)
' w( f9 \  U- J  FRequirement already satisfied: cffi>=1.12 in /usr/lib64/python2.7/site-packages (from cryptography>=2.1->openstacksdk>=0.36.0->python-openstackclient) (1.14.6)7 M; N7 R( }1 e: I1 O* g
Requirement already satisfied: msgpack>=0.5.2 in /usr/lib/python2.7/site-packages (from oslo.serialization!=2.19.1,>=2.18.0->python-novaclient>=15.1.0->python-openstackclient) (1.0.2)7 p0 _* ?8 Z, z
Requirement already satisfied: importlib-resources; python_version < "3.7" in /usr/lib/python2.7/site-packages (from netaddr>=0.7.18->oslo.utils>=3.33.0->python-openstackclient) (3.3.1)5 n" |+ L' c& _# I
Requirement already satisfied: wrapt>=1.7.0 in /usr/lib64/python2.7/site-packages (from debtcollector>=1.2.0->oslo.utils>=3.33.0->python-openstackclient) (1.12.1)# G9 }! E5 _; A. m
Requirement already satisfied: rfc3986>=1.2.0 in /usr/lib/python2.7/site-packages (from oslo.config>=5.2.0->python-keystoneclient>=3.22.0->python-openstackclient) (1.4.0)
; N. a1 N; z, v# PRequirement already satisfied: backports.functools-lru-cache>=1.2.1; python_version < "3.2" in /usr/lib/python2.7/site-packages (from wcwidth; sys_platform != "win32"->cmd2!=0.8.3,<0.9.0,>=0.8.0->cliff!=2.9.0,>=2.8.0->python-openstackclient) (1.6.4)+ o. J: Q- K4 B; p3 k' U( b7 k8 g# j
Requirement already satisfied: pycparser in /usr/lib/python2.7/site-packages (from cffi>=1.12->cryptography>=2.1->openstacksdk>=0.36.0->python-openstackclient) (2.20)) ]5 d2 |, n* q8 @0 f4 J& f
Requirement already satisfied: singledispatch; python_version < "3.4" in /usr/lib/python2.7/site-packages (from importlib-resources; python_version < "3.7"->netaddr>=0.7.18->oslo.utils>=3.33.0->python-openstackclient) (3.6.1)
4 D$ a+ |+ S( O9 {9 FRequirement already satisfied: zipp>=0.4; python_version < "3.8" in /usr/lib/python2.7/site-packages (from importlib-resources; python_version < "3.7"->netaddr>=0.7.18->oslo.utils>=3.33.0->python-openstackclient) (1.2.0)- Y) z3 o# u# y9 A3 B4 v" ]7 B
Requirement already satisfied: pathlib2; python_version < "3" in /usr/lib/python2.7/site-packages (from importlib-resources; python_version < "3.7"->netaddr>=0.7.18->oslo.utils>=3.33.0->python-openstackclient) (2.3.5)
% n4 z) i# i2 e5 R' IRequirement already satisfied: typing; python_version < "3.5" in /usr/lib/python2.7/site-packages (from importlib-resources; python_version < "3.7"->netaddr>=0.7.18->oslo.utils>=3.33.0->python-openstackclient) (3.7.4.3)
, e: y1 P+ g6 YRequirement already satisfied: scandir; python_version < "3.5" in /usr/lib64/python2.7/site-packages (from pathlib2; python_version < "3"->importlib-resources; python_version < "3.7"->netaddr>=0.7.18->oslo.utils>=3.33.0->python-openstackclient) (1.10.0)* Q, x7 e. S% W2 J# e2 h$ m

8 h# W1 z( n3 g( `再次执行openstack complete 命令,成功:
8 C+ Y: a% E- Y; ?$ U( y
; v( w/ `- z+ p  G[root@controller1 ~]# openstack complete
2 }+ b  u8 L# C4 [  h* x9 rThe 'openstack bgp speaker show dragents' CLI is deprecated and will be removed in the future. Use 'openstack bgp dragent list' CLI instead.
) _& A1 @; C& K9 D) l: x_openstack()
- h% A% j) D. x% A{# J6 _1 V2 x9 \, X1 o
  local cur prev words
9 @" f$ Z; M+ ~+ b: A% i  COMPREPLY=()
8 \& S8 b' p4 H  _get_comp_words_by_ref -n : cur prev words
+ A$ ]" z1 u! ~* c  # Command data:6 s  O6 ~5 |: w% Z: n$ g  P; p
# b& t6 R/ I5 _/ b
}
2 C( p  m7 |  a8 Q6 Vcomplete -F _openstack openstack
& `( Q" r- x% ^$ j
5 s: I  y; l: A$ ?9 P0 ]$ h9 j$ ~( ]: t* z- z2 n# D# k
  ]- |5 M# p) E* D, j  @
问题解决
2 c. e1 s$ Z0 ~' A% {+ \+ u  t/ b* a
注意重新安装的时候,yum clean all下这些yum缓存。! P. L; D5 F5 ~8 x! d9 J

# J) S0 v$ k" B其他正常安装即可。- B* k$ K6 s& v

; K* I& Y; \& x# T& `
您需要登录后才可以回帖 登录 | 开始注册

本版积分规则

关闭

站长推荐上一条 /4 下一条

如有购买积分卡请联系497906712

QQ|返回首页|Archiver|手机版|小黑屋|易陆发现 点击这里给我发消息

GMT+8, 2021-10-28 15:27 , Processed in 0.065684 second(s), 22 queries .

Powered by LR.LINUX.cloud bbs168x X3.2 Licensed

© 2012-2022 Comsenz Inc.

快速回复 返回顶部 返回列表