将设为首页浏览此站
开启辅助访问 天气与日历 收藏本站联系我们切换到窄版

易陆发现论坛

 找回密码
 开始注册
查看: 696|回复: 2
收起左侧

华为H3C设备设置vlan truk模式

[复制链接]
发表于 2021-3-9 22:23:13 | 显示全部楼层 |阅读模式

马上注册,结交更多好友,享用更多功能,让你轻松玩转社区。

您需要 登录 才可以下载或查看,没有帐号?开始注册

x
步骤:  M+ {, Z! A: s, Z; H" x. m
1 T! I1 G9 x  z) g: u$ f* ?  F* f
1.telnet 登录到交换机到控制台
8 |& n+ j" `0 ~; u$ {5 d# ?8 h( H
2.进入系统视图,创建 2到20的vlan
! u* i$ U; i( s: x2 g4 ^* l# b, d3 e' F6 P  E
<Quidway>sys1 @7 c, o( W3 g
Enter system view, return user view with Ctrl+Z.+ T0 a; c* @. G, I0 f5 ^9 `9 M
[Quidway]vlan batch 2 to 201 e2 K% l! Q6 V, K$ x1 A9 Z8 ^
Info: This operation may take a few seconds. Please wait for a moment...done.+ ^; S! W& m$ _* g+ m! a. \
[Quidway]7 M4 w9 E* v9 O+ [* d7 x, Q
! |. r, s0 `9 q* j1 C, d9 \
3.进入37口4 Y4 k/ g* B$ V. Z, ^
+ c- i6 |8 g" c- |) s! }; F# [
[Quidway]int g0/0/37
+ {) G5 o/ N; L1 s2 R/ {1 @7 [6 m[Quidway-GigabitEthernet0/0/37]/ E- y9 {; g6 Z7 F3 C
- F5 Y3 |$ A& w! D. O: Y! k
4.设置trunk
4 S: O* \6 y3 b+ u4 Y7 D! B" D) }5 [- k2 d7 ]
[Quidway-GigabitEthernet0/0/37] port link-type trunk9 C# l: q* W8 V4 c; b# k/ D

; U! i# o+ D" [9 K! ?) u) j+ W[Quidway-GigabitEthernet0/0/37] port trunk allow-pass vlan 2 to 4094
% D, }7 n" N! o7 X( i! a" D) g! f
! m* S4 E; y$ X/ I1 |Info: This operation may take a few seconds. Please wait for a moment.....done.
+ R3 W+ |$ ~0 T$ L1 E1 N! A9 o9 {[Quidway-GigabitEthernet0/0/37]: [& G$ }6 E. l! ?

- A5 M* f) I  G7 c5.查看8 K, N' E- i- A* P4 g) e% A9 {  U

1 X& Z; ^9 x% X[Quidway-GigabitEthernet0/0/37]dis this0 g" I# F5 J1 ]7 g( x" w
#9 S+ Z* v( I- y6 E) |( e( }
interface GigabitEthernet0/0/37! u" J5 @. X1 M* _' s- ^9 x
port link-type trunk
3 I& b5 x" X9 i: X4 n+ Q1 iport trunk allow-pass vlan 2 to 4094+ ?/ \. m' P4 r' A4 D, i
#1 d. l* ~) U, F/ K, s
return
9 T5 `5 n# v& H" L' R) C: i[Quidway-GigabitEthernet0/0/37]
8 d6 S) A) q' T# S& M" a' d% v1 n. y* O+ c/ P' ?
6.38口设置参照以上3、4、5操作即可
% Q7 V3 T* V' r! w+ \9 B. _; w8 g0 Y" ]! Y. r$ d% s) [4 S* D8 w/ @
7.保存设置( G' ?" |+ J( Z( s$ C1 Z5 ^: B1 ~" S
, [; G/ l5 L/ _; f9 F& o1 ^
- d, n5 N+ `/ _2 Y" G9 e
交换机配置好后,如果不保存,交换机断电或者重启后,配置就会丢失。
4 w* j. J: j. s( m* r1 ~* C所以,在配置好交换机后在  用户视图 执行 save  命令,就可以将配置保存到交换机上了。 注意必须是用户视图<Quidway>执行save命令。
( x7 L) W5 d: W8 a% ^9 A: E0 X- }9 B[Quidway]quit
, T- u+ q" j: S0 {5 t0 @+ ]<Quidway> save
. w1 X( m+ K5 X) I( ?5 d% g) k5 ]8 x6 U$ S# ^" N; D3 S
8 H* j1 q: S1 m+ x4 `5 F1 p
interface GigabitEthernet0/0/19      进入到设备接口
: E+ X4 Y7 M  \: A; ` port link-type trunk   port端口设置trunk
6 b9 ^! k0 @  U4 O, Q+ h4 _- r port trunk pvid vlan 10      L; b3 g, r  Q7 T5 h& C6 q0 Z
port trunk allow-pass vlan 2 to 4094   端口运行trunk模式下2-4094vlan可以通过
" z) t9 i( g5 A: C
5 c/ ]' e) d$ s+ s, c6 d! K7 ^. [4 \& q1 v2 Z1 L" k) V! W- p
 楼主| 发表于 2021-3-10 16:19:30 | 显示全部楼层
VLAN划分方法一般划分为4种,分别是基于端口、基于Mac、基于协议、基于IP子网。" W# X( \, O: Q! l: R
+ V- j1 O& D4 k
常用基于端口划分。
- Y. v' ]% f! X! v$ O: t
: i# v* n3 q1 q0 c4 G5 F$ \9 S一、基于端口的VLAN配置案例# v' z+ R% I6 L) X; l: A

$ C9 t' d0 y4 D% p' E  o5 v+ I/ k' x+ w, y4 y
二、基于Mac地址的划分) s# J% \" R; f) J2 Y8 T3 Z

( Q6 F/ L; B5 v( j/ E3 L1. 组网需求
! `* I% J+ j( `. t4 }l              如图1-6所示,Device A和Device C的GigabitEthernet1/0/1端口分别连接到两个会议室,Laptop1和Laptop2是会议用笔记本电脑,会在两个会议室间移动使用。/ K/ q3 P; B+ V6 u$ I
4 M# Y8 N. K' j! Y( N' a3 H8 U" E
l              Laptop1和Laptop2分别属于两个部门,两个部门间使用VLAN 100和VLAN 200进行隔离。现要求这两台笔记本电脑无论在哪个会议室使用,均只能访问自己部门的服务器,即Server1和Server2。
3 g+ M7 Z3 B0 m( ]* j8 m. `  N6 b! h5 j
l              Laptop1和Laptop2的MAC地址分别为000d-88f8-4e71和0014-222c-aa69。
( b) u2 H- i1 x; r
: {+ X% M! ^9 |8 D% ?
$ A9 p( S% g0 c/ J3 L5 ^. I4 T( n' n- c* F' O# W

2 X3 W7 }( L. m+ C5 o% F2 [# u' l0 u$ @. E
3. 配置思路$ }. Z9 H: l: y0 Q. x$ D6 k2 c
l              创建VLAN 100、VLAN 200。
  x7 n( R  O, Y3 P8 Z+ S9 G/ _& D$ V' z# n; `# }/ N; N
l              配置Device A和Device C的上行端口为Trunk端口,并允许VLAN 100和VLAN 200的报文通过。
- w1 M6 ~5 O- c% U
) U# @) i5 b& Ql              Laptop1和Laptop2的MAC地址分别与VLAN 100、VLAN 200关联。
0 \& b9 w: ]% n
( C- D# D  R# ?/ B* V1 v8 l' f4. 配置步骤
- e& e, o+ F/ m- ]! k5 D; V5 P(1)        Device A的配置4 C' h0 g: v; E2 V
& }% m" G; ]) V$ c
# 创建VLAN 100和VLAN 200。
- A9 _5 S. A; e# d' X5 s; R% d
1 i1 v8 k" l# |8 ]<DeviceA> system-view/ U4 [. g' m% f) r

; O# j& Q$ @; K) |! i! K& _' @% \[DeviceA] vlan 100! b4 z5 ]. r+ ^! N4 i2 Q

& X1 \" b$ F5 Y" ^4 t; }[DeviceA-vlan100] quit
( i! j7 l9 S. T, h/ S1 u5 E  \
9 q( S8 v# {- y1 l# Z[DeviceA] vlan 200
% ]3 n3 P; [( M" l$ d( |; Y0 ~# l4 s9 n+ G; ~# ~% V
[DeviceA-vlan200] quit
; E' c( Y& ~" q% c2 t9 ?1 M+ a3 S# c
# 将Laptop1的MAC地址与VLAN 100关联,Laptop2的MAC地址与VLAN 200关联。, D4 X; I  Q- c: ~$ V9 O3 i& i

5 f. S" T+ Y: j" ~/ \3 X[DeviceA] mac-vlan mac-address 000d-88f8-4e71 vlan 100
# X4 L9 q6 P7 J9 T3 [
3 I  `# \9 b, X: |% u[DeviceA] mac-vlan mac-address 0014-222c-aa69 vlan 2007 d* k# Z% Q) c2 B3 L+ b

- c9 X$ q( x" S$ h# 配置终端的接入端口:Laptop1和Laptop2均可能从GigabitEthernet1/0/1接入,将GigabitEthernet1/0/1的端口类型配置为Hybrid,并使其在发送VLAN 100和VLAN 200的报文时去掉VLAN Tag;开启GigabitEthernet1/0/1端口的MAC-VLAN功能。
- U# b% l2 s1 z; v3 j7 M0 O  [
8 |! M" ]4 }# Z0 P, |# o7 ^[DeviceA] interface gigabitethernet 1/0/1( @! M& d" f% @: R# x. s" ]6 I2 m
( n# K/ g* w% `) f  v
[DeviceA-GigabitEthernet1/0/1] port link-type hybrid
8 H, z; @1 R; b: s4 y" @
, C1 k3 H) j1 T! y. b[DeviceA-GigabitEthernet1/0/1] port hybrid vlan 100 200 untagged
8 @1 U' f$ q+ ~0 B7 \+ d) }! s" T: B# [1 H7 d7 K
Please wait... Done.+ L  ~- B7 m( z3 G0 h; Q! j- {, z
: I: R6 c: L: R' B$ P
[DeviceA-GigabitEthernet1/0/1] mac-vlan enable
  v3 f4 S. `0 L
8 a% X% R% V7 k+ F9 n( b[DeviceA-GigabitEthernet1/0/1] quit
# w' T9 {9 m' ^1 r5 Z5 K! C# |4 V1 u) t/ G
# 为了终端能够访问Server1和Server2,需要将上行端口GigabitEthernet1/0/2的端口类型配置为Trunk,并允许VLAN 100和VLAN 200的报文通过。
3 i7 i: w. y1 e7 w- k- p3 E( X9 u; K! a" R4 I" f
[DeviceA] interface gigabitethernet 1/0/2
: c# I' h$ A4 H- z( G' T& z  ]# Y: a& }5 c$ ~( H* @1 Y+ {' A9 z
[DeviceA-GigabitEthernet1/0/2] port link-type trunk. s" N. T& M" h0 I# U: c
% f: H) B; H+ O* o& B
[DeviceA-GigabitEthernet1/0/2] port trunk permit vlan 100 200
) p6 ~; A* c% U  [+ u" |
( Y/ k, S/ P& Z$ M  [- Z[DeviceA-GigabitEthernet1/0/2] quit& n4 e# V) }4 z+ H# ~- Q% W9 K
  P$ r5 Z& j! h7 W- c4 r8 F
(2)        Device B的配置, T' u) g  T4 W2 H6 T) M' H
  V4 y) D3 |/ P1 C+ E3 z: M0 P) ~- k" h
# 创建VLAN 100和VLAN 200,并将GigabitEthernet1/0/13加入VLAN 100,GigabitEthernet1/0/14加入VLAN 200。
5 P9 Z* y- q* Q
/ H: T: r3 _  ]  p4 p% h<DeviceB> system-view) D# @4 m0 t" x4 w  f
2 s$ p, f# ]) e0 M
[DeviceB] vlan 100# h6 ]; I+ v9 q! o0 t
5 u; M3 E! W5 z1 {3 t- M
[DeviceB-vlan100] port gigabitethernet 1/0/137 L4 `3 }8 g6 y) `! m
1 o- u4 |1 |$ q- f3 u9 x# _
[DeviceB-vlan100] quit/ i0 [+ _* L( A9 E; x+ v# J
2 L; D3 _) ]/ u1 i
[DeviceB] vlan 200* r4 d1 F5 E8 i! l- J% Y
! Q- K' W) R" w0 M
[DeviceB-vlan200] port gigabitethernet 1/0/14" O7 _6 o; R; f* _& V2 \

& G( y5 ~( Y# ~[DeviceB-vlan200] quit* J2 s: i) d  d# l4 a
* F  O5 {3 D) w& a& X7 b2 G
# 配置GigabitEthernet1/0/3和GigabitEthernet1/0/4端口为Trunk端口,均允许VLAN 100和VLAN 200的报文通过。5 k: r! p" k% N* H5 h/ Z  F
" u2 Z9 x  L0 x% r0 h( K
[DeviceB] interface gigabitethernet 1/0/31 |# q1 U; e1 x- ?9 ]$ ]; i# c( i
! E5 \2 M' ]2 ^6 ~
[DeviceB-GigabitEthernet1/0/3] port link-type trunk  `, f0 o% ?# F0 M: D
. I/ X& x( `8 C7 S, B' [) {* w
[DeviceB-GigabitEthernet1/0/3] port trunk permit vlan 100 200& T5 u# ~0 w4 P+ i& Z+ G; j3 L7 J
& k  u# y' s# q
[DeviceB-GigabitEthernet1/0/3] quit1 A. M) \' i# _% u

5 o- T7 U* w" j5 S[DeviceB] interface gigabitethernet 1/0/4
; }& @0 w" u# y% W1 ^9 L& C% z8 i
[DeviceB-GigabitEthernet1/0/4] port link-type trunk
6 v+ o; d( l0 R( J% C2 }. N- g8 E! ]" z; e" }" V+ ~" Z# d
[DeviceB-GigabitEthernet1/0/4] port trunk permit vlan 100 2001 Y9 S( ]8 E+ I# Q# N

0 Q: w  X8 K$ ^, i, E[DeviceB-GigabitEthernet1/0/4] quit3 [7 |3 U; @$ ^* s

) H4 l) G0 L, `, }* @( R(3)        Device C的配置
+ p# A) J7 t2 ?: U9 {5 f
4 `- ~: L' E% M, F% e. _& K8 HDevice C的配置与Device A完全一致,这里不再赘述。
, @  J% N- {. H0 R5 ]
* I& v  F  Y8 c; @) J三、基于协议的划分
* b% i! D; k2 U) I9 u" i& i$ R+ T: f
1. 组网需求& B) ^8 M8 E/ G5 U( l
实验室网络中大部分主机运行IPv4网络协议,另外为了教学需要还布置了IPv6实验局,因此,同时有些主机运行着IPv6网络协议。为了避免互相干扰,现要求基于网络协议将IPv4流量和IPv6流量二层互相隔离。
/ L/ a% d" K1 U" I% g, Q$ o9 _  v: C( A; M! ^0 Y
2. 组网图- V4 H6 {& c+ s' R1 O8 ^1 F
" S' h; [. K! u
4 L5 z" M0 H& u/ R2 T
5 V( {' Z& N4 o1 b$ M
* }! F/ O# _* E8 p5 m! D
3. 配置思路
2 B7 `1 g: k: w* C; K- r$ G: b创建VLAN 100及VLAN 200。让VLAN 100与IPv4协议绑定,VLAN 200与IPv6协议绑定,通过协议VLAN来实现IPv4流量和IPv6流量二层互相隔离。
- `9 k! x9 ~' c
- c! J! n& z8 L% R4. 配置步骤  @5 a" s7 p9 i# B1 W& T
(1)        配置Device% S* k  }% O5 T$ C! g! m
% T& Q* ]7 m5 {+ t7 j3 h
# 创建VLAN100,将端口GigabitEthernet1/0/11加入VLAN 100。
- a" M* T! t: [" s% i( c) O
5 i8 f% R  V/ n<Device> system-view, c  P/ b( Y% u, ~: `+ g) g
  A5 j, I  K& {& J. ^/ g
[Device] vlan 100; t& A/ }  U2 ^

/ Y1 x: n0 f+ i; f7 j[Device-vlan100] description protocol VLAN for IPv4) M) I) H7 [4 w7 w+ O
! s' \) G5 m- v& B0 O9 _  T3 S
[Device-vlan100] port gigabitethernet 1/0/116 @! Z5 s" U8 w& ?

4 B0 ?  B# S' _[Device-vlan100] quit
0 w2 z. M# L: ]9 o3 g4 w# x. \$ l/ H- u2 O$ V: v1 r
# 创建VLAN 200,将端口GigabitEthernet1/0/12加入VLAN 200。
6 p& N# Z/ h& @) _: O* H% P
% j- i% X7 F8 U7 h4 ~[Device] vlan 200
" X, d" m! t2 c$ N: z) w
. S; p( [, L0 ?[Device-vlan200] description protocol VLAN for IPv6: |& o) `, J/ A: y% ~2 h
; z, l: d* h1 V
[Device-vlan200] port gigabitethernet 1/0/128 p( D( m9 x0 m" D4 b( W

! D$ v1 z3 ^; r+ d- Y4 a# 在VLAN 200和VLAN 100视图下,分别为IPv4和IPv6协议创建协议模板。
" }: N/ t4 V, E8 o( A0 p6 Y; g; }2 q' B. _. f* x
[Device-vlan200] protocol-vlan 1 ipv61 D/ X3 j+ \% P+ ~; M" z
! a) t7 b# d  {& c! z$ M" R1 f6 \
[Device-vlan200] quit
9 z7 w! ^" @' v7 C% F! q& ^5 Y2 l, w, ]
[Device] vlan 100
& D' M( ]4 S' s" I' u: C; b" t# w& E; ^$ y0 Q( G
[Device-vlan100] protocol-vlan 1 ipv4
3 W+ q" f  q: V9 m  K. E" }5 Y) v* b. p
[Device-vlan100] quit
7 ^8 L. O, t4 X7 R; y' l0 v% h5 Q9 n( C) K. z" R4 s
# 配置端口GigabitEthernet1/0/1为Hybrid端口,并在转发VLAN 100和VLAN 200的报文时去掉VLAN Tag。3 C  M4 f. h" N
7 p9 A! c- g- ~9 y& Y- r
[Device] interface gigabitethernet 1/0/1
# T; F0 i. y6 c5 }& k( Y, x3 ]6 B4 k2 e( L2 h
[Device-GigabitEthernet1/0/1] port link-type hybrid
" V5 U% }5 e2 s! W7 ?# h7 ~( S! p1 F+ t1 P4 [; w7 g* Q' o
[Device-GigabitEthernet1/0/1] port hybrid vlan 100 200 untagged
. u9 ]! A9 g/ T% D  D5 t5 `
4 R5 |! @: _4 U, O6 [ Please wait... Done.
: y. p, F5 x* \& }4 |3 t/ [$ f$ _
# 配置端口GigabitEthernet1/0/1与VLAN 100的协议模板1(即IPv4协议模板)、VLAN 200的协议模板1(即IPv6协议模板)进行绑定。( m$ g! {) [! {. ~3 l, B
+ B+ Y9 D1 v7 b+ A9 h2 |6 z
[Device-GigabitEthernet1/0/1] port hybrid protocol-vlan vlan 100 10 Q  y8 E' H. a7 G5 z( f: W: f

9 b# @* v5 p; Q1 j[Device-GigabitEthernet1/0/1] port hybrid protocol-vlan vlan 200 1% C9 g  _3 m  y' ?+ w, V. W
7 l) ?( E5 n" y1 Q7 W& W2 a: Z
[Device-GigabitEthernet1/0/1] quit
% O9 v3 u3 P  k4 x1 w) n. y0 U6 G. M6 v1 k5 G
# 配置端口GigabitEthernet1/0/2为Hybrid端口,在转发VLAN100和VLAN200的报文时去掉VLAN Tag,与VLAN 100的协议模板1(即IPv4协议模板)、VLAN 200的协议模板1(即IPv6协议模板)进行绑定。0 g: q  `9 `8 t. h$ v+ |

( @$ s; o+ n+ M. @0 i+ h[Device] interface gigabitethernet 1/0/2
) J( W5 _( E" x' j4 |
$ J2 c( V( ~; ^[Device-GigabitEthernet1/0/2] port link-type hybrid+ S' w' g2 L; h  O

' c; y- t& s! T2 D5 v$ A[Device-GigabitEthernet1/0/2] port hybrid vlan 100 200 untagged
% h3 u( ^6 ^$ @/ f: G& Q  s: B. ~) s, m
Please wait... Done.
# C) `6 ^2 I6 T: c0 |. g! l$ b2 H6 w: E0 e
[Device-GigabitEthernet1/0/2] port hybrid protocol-vlan vlan 100 1, U, M4 @3 K& w& M3 k5 X

6 W+ t7 [! r' v, ~, l: _[Device-GigabitEthernet1/0/2] port hybrid protocol-vlan vlan 200 1) Q% A7 d  k7 H' R% p" d- y
6 x! q6 b9 C& w) t4 [9 A
(2)        L2 Switch A和L2 Switch B采用缺省配置。& S2 Z$ Y. j; c( |

! w  J& F! q/ A+ M; x' I* k(3)        将IPv4 Host A、IPv4 Host B和IPv4 Server配置在一个网段,比如192.168.100.0/24;将IPv6 Host A、IPv6 Host B和IPv6 Server配置在一个网段,比如192.168.200.0/24。
 楼主| 发表于 2021-6-2 11:00:40 | 显示全部楼层
h3c交換機埠型別有三種:access、trunk、hybrid。
; u% U4 }( U5 i# T3 |: D# n- y% |* s* B0 U- }
hybrid埠為h3c裝置私有埠,和trunk埠的區別是,trunk埠只允許一個vlan不帶標籤通過,而hybrid埠允許多個vlan不帶標籤通過。1 M0 a3 B2 ^0 Q3 z! D
: l2 s; \: p/ D  H7 o6 b3 H! i
0 l3 c" M, }" ?' i* ?$ n

# I! @5 {+ W9 r3 T在hybrid埠裡面有兩張表,tag表和untag表:% g5 L/ J8 e9 ?% s& Y) e
9 `( I) J9 O( A* V+ s
tag表: vlan帶著tag通過。例如tag表:10、20表示vlan 10或vlan 20從該埠帶著tag通過;5 K6 R6 S$ u! a+ L
, q1 E0 R; \8 y# ], `) j* V; G
untag表:vlan去掉tag通過。例如tag表:20、30表示vlan 20或vlan 30從該埠出去的時候去掉tag。0 D$ b% V3 J2 V. l

4 W2 y3 Q7 m3 N0 \; f' ?  x& F3 W2 o7 l6 F

2 `8 q# g5 k3 Z/ l下面通過課程裡的一個例項說明:
, `, N$ [, q4 p1 K- U/ m
  V: T; G. w3 o1 k7 u9 ?如圖,交換機三個埠都為hybrid埠,pca、pcb、pcb分別劃分到vlan
8 ^5 P# u% M& o0 \! m% P0 Z' g  f# B
10、vlan 20、vlan30,可以看到各埠pvid與之對應。現在要實現pca和pcb都能訪問pcc,但是pca和pcb不能相互訪問,需要:9 q* w* T( E) d! B: W/ D% d+ ^) B

) h) _! t9 o/ w  C8 S/ v5 ?
0 [/ j6 E, {* D
# W6 F: K% y3 ^① g1/0/1的hybrid裡untag表配置vlan 10、vlan 30;  l8 K( _+ C- E3 V1 T! R# a( E
1 W: w: l! v; z6 e7 I
② g1/0/2的hybrid裡untag表配置vlan 20、vlan 30;
" j1 s( {# W" f2 o, q4 Z
1 m/ l. Q  Y1 ]③ g1/0/3的hybrid裡untag表配置vlan 10、vlan 20、vlan30。
! [" X  r9 Y) i! G$ t: g( i2 L4 t7 j1 m! r* p* R9 l
' ]* n* i- p" g, L& t' ~% T: X
7 [2 J0 q, V* P  Z
這樣就可以實現了,分析如下:
6 h! r0 s( H5 V- y3 B) S2 k2 _/ m5 D' P% `
pca訪問pcc,資料發到交換機g1/0/1埠,交換機發現資料沒有tag會加上pvid也就是vlan 10的tag,然後**到g1/0/3,發現untag表裡面有10和資料帶的tag=10一樣,就會把tag去掉後傳送給pcc。8 q0 B6 z- o" V8 T$ v4 q

4 f6 f# @) N# h2 ^
7 Y( ]' I1 z9 e2 @/ T$ i
/ w* X4 ?$ ?4 e/ s9 J# O2 e到這裡別忘了pcc收到資料幀後要給pca迴應,資料先發到交換機g1/0/3埠,交換機發現資料沒有標籤會加上pvid也就是vlan 30的tag,然後**到g1/0/1,發現untag表裡面有30和資料帶的tag一樣,就會把tag去掉後傳送給pca,這樣pca和pcc就能相互訪問了。& w& o' r) U7 w( q
9 ^3 G- Z0 f9 ~$ @4 ]

, Q, m1 S7 {: m1 ~ # C+ `6 J, Y0 Q* Y# {- P  j1 k& }! f
pca訪問pccb,資料發到交換機g1/0/1埠,交換機發現資料沒有tag會加上pvid也就是vlan 10的tag,然後**到g1/0/2,發現untag表裡面只有有20、30和資料帶的tag=10不一樣,3 r' Q" ]2 G) D' v" j' ]

, E: |; b+ x* O$ a7 p0 ^: H3 E% G6 Y- d$ A9 I! N  T: _
. v  P+ T" e1 ^  U' e
這樣資料幀就沒有辦法去掉tag後傳送給pcb,而一般電腦網絡卡只能識別不帶tag的資料幀,也就是說這種情況下pca和pcb不能相互訪問。$ C9 P" f# n4 ~  J" ?5 q
3 g! s$ ^/ \) j3 H9 `% m2 ~
2樓:3度開水
' ~* e2 Q7 Y" O) C
2 b3 W* t0 J6 s* Z7 o樓上瞎扯淡呢,哪有這種介面
" e7 g0 J) `" S+ u. n9 ^  a2 [% ^/ N& A5 Y3 r6 X( V2 @5 A
fge是指fortygigabitethernet
" c9 v. O$ B" ?  q1 v- G
! }) v: V. |+ @6 T/ E
. x$ C. `/ H: K & O/ ]: m, c1 j& L( F
40g乙太網介面
; Q% G  f2 l* Q; K, N
& h8 I; u6 J7 j% e7 B' X/ j7 Nh3c交換機怎麼看所有埠狀態  g) {- e! O: S# T6 P9 E  {

% i: \) c  E7 N- V3樓:舊人不覆
( B9 t3 R! P- S. e  c2 O/ {- K9 s$ a, i( {
這條命令是檢視h3c交換機埠資訊的:display inte***ce gigabitethernet1/0/1 檢視埠資訊。+ b$ a0 N! ~4 ^
. [( U$ S/ s/ I9 H
下面的一些命令提供給樓主參考:6 x; p- e% B: z. j3 R
1 j5 C2 E6 ^% U, [3 q2 N

. q' S- J5 M0 Q7 U, D% N9 y
+ x4 ]) N9 h/ G! B7 w$ T4 u$ Zdisplay brief inte***ce gigabitethernet1/0/1 檢視埠簡要配置資訊
0 u8 W+ }7 ]2 K8 P
% y+ Y& B- e# h/ Z' ^9 `display loopback-detection 用來測試環路測試是否開啟9 O3 }) k6 w- w+ B9 O: b9 ~
  j8 w% ?9 J$ t) i9 Q
display transceiver-information inte***ce gigabitethernet1/0/50 顯示光口相關資訊
4 @5 v9 F8 I3 W' c$ W( Z  @
( ]6 C% c; T: J, d/ p/ ]1 T) E2 R7 k; @2 U/ h: Y# Q
" Z9 G5 D$ E( q" V
display port-security 檢視埠安全配置資訊
) Q& D1 d1 f& G9 E  o6 J# g& S" r) b* h9 B% W# M2 U
display garp statistics inte***ce gigabitethernet 1/0/1 顯示乙太網埠上的garp統計資訊2 S/ i% c% E; E( \- \$ w# Q

* Q6 z6 G3 c. B/ p$ v3 Y; @9 k( y$ Q; Z, J) i0 `% J; a/ g
8 c( M4 O5 T* B
希望對樓主有所幫助" q1 i' s: d" J* r
) m4 B$ X- j1 j1 h+ Y: C8 N
4樓:快去學吧! j0 {& o# O7 ]* L
. l8 s/ C" ~6 C  p
操作方法如下:
2 D# k# R. c4 r% @
  t. x& m& D& L! D. c檢視h3c交換機埠資訊的:display inte***ce gigabitethernet1/0/1 。! m- R* w, b1 V: J) G
2 x9 D" v, m; N
下面的一些命令提供參考:2 `" _2 ~. X9 e. a3 t* F
/ Z$ M- Z) z4 T- y; H
display brief inte***ce gigabitethernet1/0/1 檢視埠簡要配置資訊。4 \' z" H; s7 _' h% L

: F4 w2 {. f4 M% [# y3 F5 i* v) c, |
$ f' R/ [1 J. H7 V3 d
display loopback-detection 用來測試環路測試是否開啟。
* ?4 m( e5 B" _( U3 s  G- H  Y
5 D. J7 f  `7 _9 Cdisplay transceiver-information inte***ce gigabitethernet1/0/50 顯示光口相關資訊。! a- x% l6 s+ l3 S9 k" L/ D4 ~
$ l" x! N0 R6 N' o3 ~' z
, j, c0 a& G2 K6 q( X' K
; a5 s2 [4 J: ?3 _
display port-security 檢視埠安全配置資訊。
, Y5 ]7 W8 {. b5 \: |, _6 b3 ~4 ?. C, m7 }( v2 E  U( W
display garp statistics inte***ce gigabitethernet 1/0/1 顯示乙太網埠上的garp統計資訊。
2 G+ O4 t  B. @% j! N" H* W
# W% O- I0 Q! m; M- j3 h6 u4 n
* h/ ^. Q$ |6 _ . r; g# d$ j3 e/ h% b( j& N; s0 G) C
5樓:跳跳魚灬( z0 l* `5 W9 v3 L( ~; ]- R) G

- {  W5 X' P2 M直接登入交換機進去看裡面有個埠設定··你就可以看到了1 R! K, q8 y# G9 `6 b8 u( j# k

- l3 f6 Z1 d4 \+ m$ D4 l6樓:匿名使用者6 J7 ?$ Z* s# ]5 O$ `- j0 @
& h4 r- F% ?( U; E! F
display inte***ce brief就可以看到簡明的狀態,包含埠是up還是down的資訊0 p1 d5 C9 i0 s+ m' M4 @* X

4 f/ ]) u6 Q( l. ?$ H$ Z% ]" C7樓:左腳流的一滴淚3 [% J% M  C! z; F; i

0 z0 F6 p2 x) T# f, G+ G直接看燈或連線後命令檢視
7 p% ^9 J% y* V7 i, a- w7 G' l" p' z4 G8 E
$ _: c1 ?& w, D- o# c

! S: E6 E) k" ih3c交換機埠配置 50
' B$ X0 ^) l/ I& _7 ?( K: q
4 \2 _2 \2 s- O/ u8樓:匿名使用者
2 e+ S; M7 f0 t" s
8 t' w' F. @, i1、華三的盒式交換機,一般情況,第一個數字都是1,所以9口一般都是1/0/9,14口一般都是1/0/14,至於是g還是e,那麼就取決於你的交換機是百兆還是千兆了,如果是百兆,那麼就是e,如果是千兆,那麼就是g;
7 R" D0 d: G3 N( m% P5 \
7 k. h* }! f6 `1 L9 N3 t& Z* e0 w4 ]' r: A, w! U9 Q
& v/ w) O: t* s1 @
2、g代表的是千兆口,e代表的是百兆口,至於fe跟e一樣,ge跟g一樣;
3 J$ Y# w3 o5 j3 V8 S9 `8 `
& x- d5 `9 A! X. M- {* Z1 v3、g2/0/14,分別代表:2代表是2號槽位,0一般沒有實際意義,14代表第14號埠,華三的盒式交換機,預設一般槽位都是以1命名,所以盒式交換機你一般是不可能見著2開頭的埠的,除非你是做了虛擬化或者用命令列改過。而華為的一般都是以0開始的,所以華為的埠一般都是、0/0/1等。
您需要登录后才可以回帖 登录 | 开始注册

本版积分规则

关闭

站长推荐上一条 /4 下一条

如有购买积分卡请联系497906712

QQ|返回首页|Archiver|手机版|小黑屋|易陆发现 点击这里给我发消息

GMT+8, 2021-10-18 12:40 , Processed in 0.048641 second(s), 22 queries .

Powered by LR.LINUX.cloud bbs168x X3.2 Licensed

© 2012-2022 Comsenz Inc.

快速回复 返回顶部 返回列表