将设为首页浏览此站
开启辅助访问 天气与日历 收藏本站联系我们切换到窄版

易陆发现论坛

 找回密码
 开始注册
查看: 3026|回复: 1
收起左侧

华为交换机vlan配置

[复制链接]
发表于 2018-10-28 22:24:14 | 显示全部楼层 |阅读模式

马上注册,结交更多好友,享用更多功能,让你轻松玩转社区。

您需要 登录 才可以下载或查看,没有帐号?开始注册

x
session 1 华为交换机端口模式
  R# l4 k" k2 O. x1 Z3 a7 c8 P一、华为交换机端口分为三种模式:access、trunk、hybird
) _0 ~6 J& o) {1、access端口,用于连接主机,pvid就是该端口所属的vlan号,只能属于一个vlan+ K3 ]$ W/ O$ n! t' W$ x
2、trunk端口,用于交换机之间连接,默认pvid是vlan1,不属于任何vlan2 f0 d: ^% G! t' F0 g
3、hybird端口,是一种特殊的端口类型,默认pvid是vlan1,不属于任何vlan,是交换机端口的默认模式9 ^+ f) u! }  d  a; x% u" H" ^1 H
二、三种端口的配置命令和解释  B% V7 W" C1 D: F- v& ^# `9 p
1、access端口vlan属性
+ T: \8 S( c2 h5 c1 p[Huawei-GigabitEthernet0/0/10]display this
! q2 {8 L. L( O& R, r8 ^: i* V% k#) Q& X$ s0 F8 N1 l0 T
interface GigabitEthernet0/0/104 F. X" T3 |: Z) ~+ o1 ^& d% A* S
port link-type access                                           配置端口的模式为access
" }8 D3 X1 I. i8 d/ Y$ U# A port default vlan 2    端口属于vlan2
# Q( ?$ F" q. Z; q, |1 G- X) X. q; k#
( X7 k6 X' j1 Sreturn9 b% s' l# N; J4 `( U
2、trunk端口vlan属性) s( y/ E, e# I9 ~1 R- l
[Huawei-GigabitEthernet0/0/10]display this
( L1 G4 }7 E8 C4 k! _& Z#
! F6 w0 ?1 f; J8 w/ Ginterface GigabitEthernet0/0/103 t. f' ]8 Y3 ?
port link-type trunk   配置端口的模式为trunk
* q( Q; [, o, ~! u. T3 f& ` port trunk pvid vlan 2   配置端口的pvid为vlan2  F* d6 j/ N0 A% t8 A) {% y( O
port trunk allow-pass vlan 2 to 10   配置trunk允许进入的vlan-id,允许vlan1-vlan10(vlan1默认允许)
, P( o0 @, X9 _- }, U% L) P' j#+ D- s, q- @3 x4 [9 A6 _3 t6 f
return
8 [2 M9 K, T5 S* ?; t! G$ i9 r3、hybird端口vlan属性
- k/ W5 R  z! Y0 n  ^% F: P$ M[Huawei-GigabitEthernet0/0/10]display this
( u& {" d! l1 M$ z1 J8 T& M5 u/ ?3 e#0 Y9 `* ]9 J! Z4 l$ Y3 y0 \0 d( t
interface GigabitEthernet0/0/10 配置端口模式为hybrid3 y' q. Z8 y5 N8 c
port hybrid pvid vlan 2 配置端口的pvid是20 t6 A  x, u! s) A
port hybrid tagged vlan 10 配置端口在发送帧时不将帧中的vlan10的标签去掉(类似trunk功能), h: L  i4 p8 M5 N! R3 e
port hybrid untagged vlan 2 配置端口在接到帧后移除vlan2的标签后转发(给主机): C6 k; @( N8 ^% E8 J
#
  |+ U" w& ~% q* Breturn
% V4 n3 W! p- L3 O* i$ I$ |  G* Y2 k0 K3 e6 [6 u" O
pvid的作用,分为端口接收和发送数据两个方向:
- g( o7 u+ n) p1 m8 ]0 w. }. }1、当端口收到一个未标记的帧时,就把该帧打上vlan id,这个id值等于pvid的值,然后转发到VID和PVID相等的VLAN 中。
' m5 U8 @3 a( D& j2、当帧从端口向外发送出去时,如果帧头中的VID和端口的PVID值相同,就把这个标识去掉,再送出去。$ Q& k0 R2 K+ H  T1 ?9 k& V
下面例子解释pvid的双向作用:
! B* }3 f  M/ L7 o! v! `: X4 ^, U3 t
       整个拓扑中PC1连接在sw1的g/0/1口,vlan1,PC2连接在sw2的g/0/1接口,vlan2( |* W: x/ _% v: F, b
       SW1和SW2的g0/0/3接口都是trunk模式,其中sw1的g0/0/3接口的pvid是1,sw2的g0/0/3接口的pvid是2,并且两端trunk都允许vlan 1 to 2的帧通过。
9 ~/ X3 r6 z+ c1 `% m- H       这样配置下来的结果是pc1和pc2只要在同一个网段内就可以通信,虽然vlan不同,但是可以通信。$ ~* Q5 V# u/ h7 y! u
1、pc1发送数据包给pc2过程是:pc1发送一个去往PC3的数据包到达sw1的e0/0/1接口,由于该接口属于vlan1所以sw1将受到的pc1的数据帧打上vlan1的标签(无标签),然后sw1查找PC3的mac,发现在接口g0/0/3下于是将数据包发给g0/0/3接口,当g0/0/3接口收到这个pc1发来的不打vlan标签的vlan1的帧后,就要将这个不打tag的帧发送出去,发现这个帧的VID和自己的PVID=1是相同的都是vlan1的于是就要把这个帧的tag去掉(vlan1默认就没有tag所以这里不做操作转发出去)然后转发出去。然后这个由PC1发来的帧被sw2在自己的g0/0/3接口收到,sw2发现收到的这个帧是没有tag的普通帧并且trunk接口的配置是允许vlan1、2通过所以会接收这个数据帧,并查看自己的pvid=2,于是就将这个数据包打上vlan2的tag,然后在vlan2的MAC表中查找PC3的mac地址发现在自己的e0/0/1接口上,于是将数据包转发到PC3。+ b4 J1 R" k8 r* s& p: _
2、PC3收到PC1发来的数据包后需要给PC1回包,PC3回给PC1的包经过sw2的g0/0/1后被打上了vlan2的tag,到达g0/0/3接口,SW2发现PC3发来的这个帧有tag是vlan2,而自己的pvid=2,于是就将这个tag去掉,而接口又允许vlan1、2通过,于是就将这个去掉了tag的数据包通过g0/0/3接口转发出去,被sw1在g0/0/3接口收到,sw1查看自己的trunk配置发现接口允许vlan1、2通过就接收这个帧,然后检查该帧的VID,发现没有,于是打上vlan1的tag(也就是没有tag),然后在vlan1的MAC表中查找PC1的mac地址,发现PC1连接在自己的e0/0/1接口,就会把帧从e0/0/1接口发送给PC1,这样就完成了一次PC1与PC3的互通。
% G( b' Z- `. v* B# N, r交换机SW1上的配置:
6 S1 d7 O/ p- L* _/ Q[SW1-GigabitEthernet0/0/3]display this
+ D* o" d5 t, j% j- Q4 I#: C( l. E$ w3 _/ Y9 _+ n
interface GigabitEthernet0/0/30 x1 k1 ]- t3 w- k2 }2 i
port link-type trunk- f, ?' @% Q1 M
port trunk allow-pass vlan 2                          端口pvid=1(默认)并允许vlan1、2的帧进入sw1
$ f- b+ O" I* d( r) F/ F/ c* [#
  c2 `& i6 X! V; H' Xreturn. [2 t; I+ k5 M) }5 y$ v; I/ y
[SW1-GigabitEthernet0/0/1]display this ! T' C" i5 X! v: P
#
2 R- Z1 N4 A; q9 J% `interface GigabitEthernet0/0/1
; K3 y1 s" g7 E' r+ Y/ } port link-type access                                     端口默认属于vlan1,连接的是pc1
6 a# c3 J3 R! a/ P, q- w0 y#
2 J9 _. C* L( X7 u1 yreturn
. t* W3 Z. j  D" w3 }2 g交换机SW2上的配置:
* {1 s3 Y, Q& T7 y[SW2-GigabitEthernet0/0/3]display this 4 S/ l: m5 W- g8 F
#
& V$ D  X4 g* _: x( {interface GigabitEthernet0/0/3
, @  o! g1 R- e/ u/ }8 U* h+ O port link-type trunk
' E% r* j3 ~4 L, y port trunk pvid vlan 2                                   端口的pvid=2            ( X8 `/ Y4 G7 b
port trunk allow-pass vlan 2                         端口允许vlan1、2的帧进入sw26 B! W$ @" E. J# F, z* ~
#
( U5 I" H  ^3 `- j+ n6 Ureturn6 Q' D& p0 t5 R. D3 a
[SW2-GigabitEthernet0/0/1]display this . q1 h# C$ g0 Q$ J
#6 j  r- |" v3 I
interface GigabitEthernet0/0/1
1 u! H+ ?! y/ a! {& D! f& G$ B port link-type access7 r* h3 Q! J4 H; d
port default vlan 2                                        端口属于vlan2,连接的是pc2
. [2 M# s) T! o7 p" n  H#
! ~' y: u8 L( F; M- f: ereturn
( k% i/ Y5 J( {PC端的配置:
# r* o: t9 i7 ]2 n1 d( ?- k* TPC1:192.168.1.10/24
  ?# s5 Y+ ~* C) FPC2:192.168.1.30/24
, M' x% G. |- z测试连通性" d& L! e7 V7 Z9 ?
PC1>ipconfig
; S( B- H: e( c; ?+ Y- rLink local IPv6 address...........: fe80::5689:98ff:fec3:22c4- w  K6 j" z* ]8 U3 b* p! E, q
IPv6 address......................: :: / 128
* S+ s2 P! n! J  a# b( {+ R/ lIPv6 gateway......................: ::
) d3 ~  a3 m6 E7 V( y2 a' LIPv4 address......................: 192.168.1.10
2 j7 x) ]/ k$ k; _4 R( r3 FSubnet mask.......................: 255.255.255.0/ w. e7 m6 l" {5 \. d# ?' `& J9 i
Gateway...........................: 0.0.0.0
  H& {) _: m, D1 APhysical address..................: 54-89-98-C3-22-C4
5 e$ V2 G6 n+ t- l$ z9 pDNS server........................:% `* T3 f# Z) A' p" v$ B* L4 c9 g/ }
PC1>ping 192.168.1.30. d/ M( ?/ d% r7 p) o8 t
Ping 192.168.1.30: 32 data bytes, Press Ctrl_C to break% K) o: D/ z0 y5 V; ?0 E& v7 J
From 192.168.1.30: bytes=32 seq=1 ttl=128 time=62 ms! R2 y2 |$ E4 R3 W& Z; q
--- 192.168.1.30 ping statistics ---
+ v" L" f/ z( X0 P; `9 ^: Q  1 packet(s) transmitted
4 t" |4 F% a  m9 q  1 packet(s) received
; i" ^% ~0 j% q  0.00% packet loss7 K9 Y7 j3 |7 d
  round-trip min/avg/max = 62/62/62 ms
- ?+ s% u1 B( f3 WPC1>9 T9 l! k# y5 Z3 q, D3 o3 |
4 t& e0 U7 ^9 _5 W( F" G
[Huawei]clear configuration interface g0/0/1      清除接口配置,恢复默认
; L2 X# j( V/ S; {$ j, I9 z8 N1 J- q0 S( W: ~0 M
在hybird模式中的tag和untag:
: ~: V# b: A, W. F: F) h* y       tag是指允许通过的tag的帧,功能类似trunk的allow-vlan。untag是指当接口收到帧的时候去除哪个tag,untag=2就是收到vlan2的数据帧后将tag去掉还原成普通的帧(发给主机),类似于access接口的功能。所以hybrid模式是trunk和access接口功能的集合,可以灵活使用。
7 g- T  ]" a( q# w9 t) t- k% W下面几个vlan划分的类型来学习hybrid端口的用法:4 |$ c, F8 \1 j0 j( \8 K' i
1、基于端口的vlan划分,这个就是普通的使用access模式做的,一般都用这个模式
' r& k* Z) r) }1 K2、基于ip地址的vlan划分,这个是用hybrid模式做,用于主机移动的办公环境(比如公司经常部门调整地理位置),原理是将vlan-id与ip网段进行映射绑定,只要主机的ip网段不变,那么他不管连接那个sw的那个接口都属于同一个vlan,不用担心频繁换地区导致连接sw的端口需要进行vlan的调整5 ]4 Y- O1 c! [
6 ^  q6 H4 w% Z. j
配置如下:
: ?0 E7 T5 l& i首先将ip网络与vlan进行绑定,分别在sw1和sw2中创建vlan并绑定相应的ip网段(SW1与SW2配置相同,只以sw1为例), K7 P# [# J3 j/ @
vlan 2" S6 Q# K/ b3 l2 F. l
ip-subnet-vlan 2 ip 192.168.1.0 255.255.255.0             将192.168.1.0/24与vlan2绑定,红色的数字2是id号,不是vlan号,可以随意设置但是
2 w% O, ]; [( T& N% ~#                                                                                      一个vlan中最多可以绑定最多12个子网网段,只有12个id号9 w  Y- ^! S+ f8 p2 `6 i
配置sw1与sw2的级联trunk端口,并允许所有vlan通过
4 y+ v7 [- o4 k% g0 g8 r' B4 t[SW1-GigabitEthernet0/0/3]display this - v2 _9 y/ J; V2 T  j
#
7 L) O" a; b7 X7 Dinterface GigabitEthernet0/0/3' Y7 N5 n, Z+ q2 y9 U% b
port link-type trunk
$ k# e; _; \0 e" G0 R8 I; G port trunk allow-pass vlan 2 to 4094                          允许所有vlan通过trunk& P$ F' S! x7 h. x/ |
#
3 U* {/ @$ R% ?) ?return! z' F! D0 Z. Z  X
配置sw1连接PC的g0/0/1端口为hybrid模式,并且只允许vlan2的数据帧通过(去除vlan2的标签给pc,收到其他vlan的数据就不会去掉标签直接发给pc,而pc不能识别带有vlan标识的帧从而丢弃数据帧,达到将pc的ip绑定在vlan2中)) |3 Y; }# S# l6 F2 p
[SW1-GigabitEthernet0/0/1]display this ) {/ h- `/ `! A* O" G8 P) r
#0 t' W! n0 j- b3 x
interface GigabitEthernet0/0/1$ Y# c! ?3 @* ?9 S+ h
port hybrid untagged vlan 2                                      在发送帧(给PC)时只去掉vlan2的标签(带有其他vlan的帧不会去掉标签)
9 d$ T2 P( c+ H8 U  V6 U- j vlan precedence ip-subnet-vlan                                配置优先使用基于ip划分的vlan模式(默认使用基于端口的vlan模式)
! w9 z& `) h2 |# x& U! U ip-subnet-vlan enable                                                启用基于ip网络的vlan划分: `, W* d) y) _1 N
#2 g: H& u; S; s6 q" H! t
return
2 F- C/ |: ^6 u% s; @- k3 N       验证方法是将sw1或者sw2的g0/0/1端口port hybrid untagged vlan 2修改为其他vlan-id后pc之间就无法通信,可以抓包查看帧的vlan-id。或者将pc1与pc2的ip地址改为192.168.2.x也不通,是因为vlan2只绑定了192.168.1.0/24而没有绑定其他网段,而端口又只untag了vlan2的帧。
  _2 `) v- q/ u' I3、基于mac地址的vlan划分,与基于ip的vlan划分一样使用hybrid模式做,功能和基于ip地址的vlan划分类似
! y6 p; I) C/ R首先将pc的mac地址与vlan绑定,SW1与SW2配置相同,在vlan2中绑定pc1和pc37 E  ?6 \0 ~) }' f
vlan 2                              
: O+ M" `9 D5 g. s) C mac-vlan mac-address 5489-98c3-22c4 priority 04 k, f$ S& y; y
mac-vlan mac-address 5489-98ce-1433 priority 0% u* b" x/ j& ~1 C7 k3 a' ^1 @
配置sw1与sw2之间的trunk端口,允许所有vlan帧通过% s1 j- N  i5 Z/ C' M
interface GigabitEthernet0/0/3
' j7 n& u  P# U  K/ g7 n( {+ R port link-type trunk
! D2 I' U) O, j: v0 D* J# B port trunk allow-pass vlan 2 to 40949 c4 q" I# p4 F: p3 f
#
8 A1 |$ a( D9 T配置sw连接pc的接口的vlan模式优先使用mac划分vlan模式(hybrid端口默认就是mac-vlan模式),开启基于mac地址的vlan划分
! L( i2 K# b' q2 _interface GigabitEthernet0/0/1
$ E6 w+ y0 G) v1 S6 h port hybrid untagged vlan 2                           允许vlan2的帧通过,在发送帧(给PC)时只去掉vlan2的标签(带有其他vlan的帧不会去掉标签)
- G+ c/ }6 p! \' R% @# D' G$ c6 f mac-vlan enable                                              开启基于mac地址的vlan划分* h3 `" ]! t1 n7 f
#
+ w2 Z, Y4 `8 {8 G8 k6 ^       验证方法与基于ip的vlan划分一样,或者可以将pc1与pc3改为其他网络,依然能通信,是因为使用的是基于mac的vlan划分,所以只要mac在一个vlan内,那么不管ip如何变化只要在一个网段内都能通信。% ^/ i* \" V* r6 S) D

0 i6 Q3 U& w* J% C: f
 楼主| 发表于 2018-10-28 22:25:01 | 显示全部楼层
步骤:% F; l1 I9 [. s6 y8 q! `
+ o1 z& l& u( h* t
1.telnet 登录到交换机到控制台1 [# y# ~" A; v

! j% O0 f+ X1 R# r; A! L2.进入系统视图,创建 2到20的vlan, P& Y8 S. {- ^
1 [/ y% c( ]  r6 |  A
<Quidway>sys  \: `1 @. L1 X, n: d$ F2 t
Enter system view, return user view with Ctrl+Z.
* z/ A( ~3 \. f$ I) Y- n( s; E[Quidway]vlan batch 2 to 206 `1 O# L1 L" y8 n  n8 p
Info: This operation may take a few seconds. Please wait for a moment...done.% k" a) x, ~% M) U% ?
[Quidway]
2 r! Z/ p. a7 {& p$ L* ~8 }
# |2 i9 N$ i3 _& M$ q5 S0 {2 _. V9 C2 d3.进入37口- X  }; h% o3 L$ @8 t5 t
' a) t- ~* z" O( a+ M% Q, H* a
[Quidway]int g0/0/37' ~2 d; n* H: E9 [6 [. p0 I
[Quidway-GigabitEthernet0/0/37]
+ w9 A- q7 K* O" C( y/ ?% l5 O, ?* q2 T) {; v" g9 z7 l, W7 R: B
4.设置trunk
8 U* Z- n6 b  w- [2 T2 f' X2 p
- R/ U1 H) v5 D9 o7 f. v[Quidway-GigabitEthernet0/0/37] port link-type trunk. }/ n# ]$ R8 O7 I8 [7 N( O5 L
% q) N" l- S& T$ c
[Quidway-GigabitEthernet0/0/37] port trunk allow-pass vlan 2 to 40940 {, ^$ F/ K# a7 K# e% f! F2 l
# O9 T9 m$ ^! |7 G% F9 f
Info: This operation may take a few seconds. Please wait for a moment.....done.  Q+ {! O' ]- {; w1 T2 a
[Quidway-GigabitEthernet0/0/37]
; @3 |& _9 \) C8 C. }- {' P8 P( J4 j9 N. w/ B4 n
5.查看3 w& X2 P* C1 a( H" Z/ g
) d4 w% m) n4 v8 S
[Quidway-GigabitEthernet0/0/37]dis this- H- e' m. C3 L6 c6 S# U
#9 |2 b/ i/ O& e: K9 x
interface GigabitEthernet0/0/37
: L( p5 N, N0 f. i. g port link-type trunk
* G& W, J% d" q0 v' X$ ^# D port trunk allow-pass vlan 2 to 4094. e# j7 [3 S2 z2 H4 k# c" h
#
' N0 U9 @  ?: J- Preturn8 Y7 V. j$ j3 D$ z6 |; C
[Quidway-GigabitEthernet0/0/37]* L5 i6 b7 Q3 C0 m; T( l
4 H5 ~( ]0 {7 W* T7 R1 }) i/ V
6.38口设置参照以上3、4、5操作即可
/ M, d1 v9 w! V7 O0 \( m& }/ D
( @# g  R7 I/ T5 w" d7.保存设置
0 O) z' n* z8 x  {; x5 o# N, o
; N5 B' U. z5 q# P% k. `
  l" q- C* S8 p* H5 z# e2 D交换机配置好后,如果不保存,交换机断电或者重启后,配置就会丢失。
2 q8 T+ }8 z" J7 D9 E8 P1 g3 P所以,在配置好交换机后在  用户视图 执行 save  命令,就可以将配置保存到交换机上了。 注意必须是用户视图<Quidway>执行save命令。! _5 j8 G6 ^4 T/ A; p: P' u% z
[Quidway]quit$ o! n& i  p4 C
<Quidway> save
9 ^2 U" p* Q6 Z( w: Z( [0 c& P* Y$ m& O* M& \+ A+ K
您需要登录后才可以回帖 登录 | 开始注册

本版积分规则

关闭

站长推荐上一条 /4 下一条

如有购买积分卡请联系497906712

QQ|返回首页|Archiver|手机版|小黑屋|易陆发现 点击这里给我发消息

GMT+8, 2021-10-20 09:46 , Processed in 0.045969 second(s), 22 queries .

Powered by LR.LINUX.cloud bbs168x X3.2 Licensed

© 2012-2022 Comsenz Inc.

快速回复 返回顶部 返回列表